[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20150916152540.b19aebc9f7a0889685867f1a@linux-foundation.org>
Date: Wed, 16 Sep 2015 15:25:40 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Vineet Gupta <Vineet.Gupta1@...opsys.com>
Cc: "Aneesh Kumar K.V" <aneesh.kumar@...ux.vnet.ibm.com>,
"Kirill A. Shutemov" <kirill.shutemov@...ux.intel.com>,
Mel Gorman <mgorman@...e.de>,
"Matthew Wilcox" <matthew.r.wilcox@...el.com>,
Minchan Kim <minchan@...nel.org>, <linux-arch@...r.kernel.org>,
<linux-kernel@...r.kernel.org>, <linux-mm@...ck.org>,
<arc-linux-dev@...opsys.com>
Subject: Re: [PATCH 08/11] mm,thp: reduce ifdef'ery for THP in generic code
On Thu, 27 Aug 2015 14:33:11 +0530 Vineet Gupta <Vineet.Gupta1@...opsys.com> wrote:
> This is purely cosmetic, just makes code more readable
>
> ...
>
> --- a/include/asm-generic/pgtable.h
> +++ b/include/asm-generic/pgtable.h
> @@ -30,9 +30,20 @@ extern int ptep_set_access_flags(struct vm_area_struct *vma,
> #endif
>
> #ifndef __HAVE_ARCH_PMDP_SET_ACCESS_FLAGS
> +#ifdef CONFIG_TRANSPARENT_HUGEPAGE
> extern int pmdp_set_access_flags(struct vm_area_struct *vma,
> unsigned long address, pmd_t *pmdp,
> pmd_t entry, int dirty);
> +#else /* CONFIG_TRANSPARENT_HUGEPAGE */
> +static inline int pmdp_set_access_flags(struct vm_area_struct *vma,
> + unsigned long address, pmd_t *pmdp,
> + pmd_t entry, int dirty)
> +{
> + BUG();
> + return 0;
> +}
Is it possible to simply leave this undefined? So the kernel fails at
link time?
> --- a/mm/pgtable-generic.c
> +++ b/mm/pgtable-generic.c
Good heavens that file is a mess. Your patch does improve it.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists