[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20150922130332.GA12815@twin.jikos.cz>
Date: Tue, 22 Sep 2015 15:03:32 +0200
From: David Sterba <dsterba@...e.cz>
To: Alexandru Moise <00moses.alexander00@...il.com>
Cc: clm@...com, jbacik@...com, dsterba@...e.com,
linux-btrfs@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] btrfs: cleanup btrfs_balance profile validity checks
On Sun, Aug 30, 2015 at 09:45:49PM +0000, Alexandru Moise wrote:
> Improve readability by generalizing the profile validity checks,
> I had to read through those if statements half a dozen times on my
> first try just to get an idea of what's happening there.
>
> Signed-off-by: Alexandru Moise <00moses.alexander00@...il.com>
> ---
> fs/btrfs/volumes.c | 21 ++++++++++++---------
> 1 file changed, 12 insertions(+), 9 deletions(-)
>
> diff --git a/fs/btrfs/volumes.c b/fs/btrfs/volumes.c
> index fbe7c10..d23bc26 100644
> --- a/fs/btrfs/volumes.c
> +++ b/fs/btrfs/volumes.c
> @@ -3454,6 +3454,15 @@ static void __cancel_balance(struct btrfs_fs_info *fs_info)
> atomic_set(&fs_info->mutually_exclusive_operation_running, 0);
> }
>
> +/* Non-zero return value signifies invalidity */
> +static inline int balance_relocate_invalid(struct btrfs_balance_args *bctl_arg,
The function name is not very descriptive, I'd pick something like
validate_convert_profile, otherwise ok.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists