[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1442928763-4425-1-git-send-email-bywxiaobai@163.com>
Date: Tue, 22 Sep 2015 21:32:43 +0800
From: Yaowei Bai <bywxiaobai@....com>
To: akpm@...ux-foundation.org, uobergfe@...hat.com, dzickus@...hat.com,
atomlin@...hat.com, cmetcalf@...hip.com, fweisbec@...il.com,
eranian@...gle.com
Cc: linux-kernel@...r.kernel.org
Subject: [PATCH] kernel/watchdog: is_hardlockup can be boolean
This patch makes is_hardlockup return bool to improve readability
due to this particular function only using either one or zero as its
return value.
No functional change.
Signed-off-by: Yaowei Bai <bywxiaobai@....com>
---
kernel/watchdog.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/kernel/watchdog.c b/kernel/watchdog.c
index 64ed1c3..568ba64 100644
--- a/kernel/watchdog.c
+++ b/kernel/watchdog.c
@@ -263,15 +263,15 @@ void touch_softlockup_watchdog_sync(void)
#ifdef CONFIG_HARDLOCKUP_DETECTOR
/* watchdog detector functions */
-static int is_hardlockup(void)
+static bool is_hardlockup(void)
{
unsigned long hrint = __this_cpu_read(hrtimer_interrupts);
if (__this_cpu_read(hrtimer_interrupts_saved) == hrint)
- return 1;
+ return true;
__this_cpu_write(hrtimer_interrupts_saved, hrint);
- return 0;
+ return false;
}
#endif
--
1.9.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists