[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20150922155338.GO63416@redhat.com>
Date: Tue, 22 Sep 2015 11:53:38 -0400
From: Don Zickus <dzickus@...hat.com>
To: Yaowei Bai <bywxiaobai@....com>
Cc: akpm@...ux-foundation.org, uobergfe@...hat.com, atomlin@...hat.com,
cmetcalf@...hip.com, fweisbec@...il.com, eranian@...gle.com,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] kernel/watchdog: is_hardlockup can be boolean
On Tue, Sep 22, 2015 at 09:32:43PM +0800, Yaowei Bai wrote:
> This patch makes is_hardlockup return bool to improve readability
> due to this particular function only using either one or zero as its
> return value.
>
> No functional change.
Looks fine.
Acked-by: Don Zickus <dzickus@...hat.com>
>
> Signed-off-by: Yaowei Bai <bywxiaobai@....com>
> ---
> kernel/watchdog.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/kernel/watchdog.c b/kernel/watchdog.c
> index 64ed1c3..568ba64 100644
> --- a/kernel/watchdog.c
> +++ b/kernel/watchdog.c
> @@ -263,15 +263,15 @@ void touch_softlockup_watchdog_sync(void)
>
> #ifdef CONFIG_HARDLOCKUP_DETECTOR
> /* watchdog detector functions */
> -static int is_hardlockup(void)
> +static bool is_hardlockup(void)
> {
> unsigned long hrint = __this_cpu_read(hrtimer_interrupts);
>
> if (__this_cpu_read(hrtimer_interrupts_saved) == hrint)
> - return 1;
> + return true;
>
> __this_cpu_write(hrtimer_interrupts_saved, hrint);
> - return 0;
> + return false;
> }
> #endif
>
> --
> 1.9.1
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists