[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150930083023.GC29589@js1304-P5Q-DELUXE>
Date: Wed, 30 Sep 2015 17:30:23 +0900
From: Joonsoo Kim <iamjoonsoo.kim@....com>
To: Vlastimil Babka <vbabka@...e.cz>
Cc: Andrew Morton <akpm@...ux-foundation.org>,
linux-kernel@...r.kernel.org, linux-mm@...ck.org,
Mel Gorman <mgorman@...e.de>, Rik van Riel <riel@...hat.com>,
David Rientjes <rientjes@...gle.com>,
Minchan Kim <minchan@...nel.org>
Subject: Re: [PATCH v2 5/9] mm/compaction: allow to scan nonmovable pageblock
when depleted state
On Fri, Sep 25, 2015 at 12:32:02PM +0200, Vlastimil Babka wrote:
> On 08/24/2015 04:19 AM, Joonsoo Kim wrote:
>
> [...]
>
> >
> > Because we just allow freepage scanner to scan non-movable pageblock
> > in very limited situation, more scanning events happen. But, allowing
> > in very limited situation results in a very important benefit that
> > memory isn't fragmented more than before. Fragmentation effect is
> > measured on following patch so please refer it.
>
> AFAICS it's measured only for the whole series in the cover letter, no? Just to
> be sure I didn't overlook something.
It takes too much time so no measurement is done on every patch.
I will try to measure it on at least this patch in next revision.
>
> > Signed-off-by: Joonsoo Kim <iamjoonsoo.kim@....com>
> > ---
> > include/linux/mmzone.h | 1 +
> > mm/compaction.c | 27 +++++++++++++++++++++++++--
> > 2 files changed, 26 insertions(+), 2 deletions(-)
> >
> > diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
> > index e13b732..5cae0ad 100644
> > --- a/include/linux/mmzone.h
> > +++ b/include/linux/mmzone.h
> > @@ -545,6 +545,7 @@ enum zone_flags {
> > */
> > ZONE_FAIR_DEPLETED, /* fair zone policy batch depleted */
> > ZONE_COMPACTION_DEPLETED, /* compaction possiblity depleted */
> > + ZONE_COMPACTION_SCANALLFREE, /* scan all kinds of pageblocks */
>
> "SCANALLFREE" is hard to read. Otherwise yeah, I agree scanning unmovable
> pageblocks is necessary sometimes, and this seems to make a reasonable tradeoff.
Good! I will think better name.
Thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists