lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 06 Oct 2015 09:20:53 +0200
From:	Olliver Schinagl <>
To:	Thierry Reding <>,,
	"" <>
CC:	Olliver Schinagl <>
Subject: [RFC] pwm: chip_data vs device_data

Hey Thierry, list,

While working on something in the pwm framework, I noticed that the void 
*data in the pwm_device struct is called chip_data. Why is it not called 
device_data, since it is the data associated with a PWM device, rather 
then the chip, and on that note, if it really is chip related data (thus 
covering the whole chip, not just the single pwm device) why is there no 
chip_data in pwm_chip?

Again, is this something worth my time to add a device_data and rename 

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists