lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Tue, 06 Oct 2015 21:28:59 +0900
From:	Chanwoo Choi <>
To:	Roger Quadros <>,
Subject: Re: [PATCH 2/2] extcon: Add the support of EXTCON_CHG_USB when SDP
 port is attached or detached


On 2015년 10월 06일 21:22, Roger Quadros wrote:
> Chanwoo,
> On 06/10/15 15:12, Chanwoo Choi wrote:
>> Roger,
>> On 2015년 10월 06일 20:49, Roger Quadros wrote:
>>> Hi,
>>> On 06/10/15 14:21, Chanwoo Choi wrote:
>>>> The SDP (Standard Downstream Port) is one of various USB Charging ports. The SDP
>>>> supports both the data transmission and the charging through USB connector at
>>>> the same time. So, the EXTCON framework defines two connector type for USB SDP
>>>> connector as following:
>>>> - EXTCON_USB means the USB cable for data transmission.
>>>> - EXTCON_CHG_USB means the USB charger cable for battery charging.
>>>> This patch add the support of EXTCON_CHG_USB when USB SDP is attached or
>>>> detached.
>>> I didn't understand why this change is needed. SDP, EXTCON_USB and EXTCON_CHG_USB
>>> are the same thing. no?
>> As you knew, SDP support both data transmission and charging
>> through one port at the same time. Also, On patch1 of this patch-set,
>> I add the prefix to clarify both attribute and meaning of external connector as following:
>> - EXTCON_CHG_* mean the charger connector.
>> So, there are three possible naming approach for USB SDP.
>> Approach 1.
>> - EXTCON_USB		/* SDP for both data transmission and charging */
>> Approach 2.
>> - EXTCON_USB		/* SDP for data transmission */
>> - EXTCON_CHG_USB	/* SDP for charging */
> This only adds confusion. There is only one cable that will always do both jobs
> so no point in using 2 names for it.

OK. I'll drop it.

>> Approach 3.
>> - EXTCON_CHG_USB	/* SDP for both data transmission and charging */
>> It is not fixed about name. I want to discuss what is proper name for USB SDP.
> I do not have any preference over 1 or 3.

I'll drop this patch. Also, I'll use only EXTCON_USB and delete the EXTCON_CHG_USB
from patch1 on next version.

Chanwoo Choi
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists