[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20151019093231.GA29389@kwain>
Date: Mon, 19 Oct 2015 11:32:31 +0200
From: Antoine Tenart <antoine.tenart@...e-electrons.com>
To: Ezequiel Garcia <ezequiel@...guardiasur.com.ar>
Cc: Antoine Tenart <antoine.tenart@...e-electrons.com>,
sebastian.hesselbarth@...il.com,
ezequiel.garcia@...e-electrons.com, dwmw2@...radead.org,
computersforpeace@...il.com, zmxu@...vell.com, jszhang@...vell.com,
linux-kernel@...r.kernel.org, linux-mtd@...ts.infradead.org,
linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH v3 2/4] mtd: pxa3xx_nand: add helpers to setup the timings
Ezequiel,
On Sat, Oct 17, 2015 at 10:57:26AM -0300, Ezequiel Garcia wrote:
> On 15 Oct 09:17 AM, Antoine Tenart wrote:
> > /*
> > * Set the data and OOB size, depending on the selected
> > * spare and ECC configuration.
> > @@ -1538,6 +1660,19 @@ KEEP_CONFIG:
> > if (nand_scan_ident(mtd, 1, def))
> > return -ENODEV;
> >
> > + if (!pdata->keep_config) {
> > + ret = pxa3xx_nand_init(host);
> > + if (ret) {
> > + dev_err(&info->pdev->dev, "Failed to init nand: %d\n",
> > + ret);
> > + return ret;
> > + }
> > + }
> > +
> > + ret = pxa3xx_nand_config_flash(info);
> > + if (ret)
> > + return ret;
> > +
>
> Does this chunk belong to this patch? It wasn't here in the v2, and I believe
> it's not correct as you end up messing with the NDCR setting even if keep_config
> was passed.
You're right, it should be in "[3/4] mtd: pxa3xx_nand: rework flash
detection and timing setup". I made a mistake reworking the series...
And yes, pxa3xx_nand_config_flash() should be called before
"KEEP_CONFIG:".
Antoine
--
Antoine Ténart, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists