[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20151020160609.GH17308@twins.programming.kicks-ass.net>
Date: Tue, 20 Oct 2015 18:06:09 +0200
From: Peter Zijlstra <peterz@...radead.org>
To: Paolo Bonzini <pbonzini@...hat.com>
Cc: Daniel Wagner <daniel.wagner@...-carit.de>,
linux-kernel@...r.kernel.org, linux-rt-users@...r.kernel.org,
Marcelo Tosatti <mtosatti@...hat.com>,
"Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>,
Paul Gortmaker <paul.gortmaker@...driver.com>,
Thomas Gleixner <tglx@...utronix.de>
Subject: Re: [PATCH v3 2/4] KVM: use simple waitqueue for vcpu->wq
On Tue, Oct 20, 2015 at 05:40:36PM +0200, Paolo Bonzini wrote:
>
>
> On 20/10/2015 16:00, Peter Zijlstra wrote:
> >> > - prepare_to_wait(&vcpu->wq, &wait, TASK_INTERRUPTIBLE);
> >> > + prepare_to_swait(&vcpu->wq, &wait, TASK_INTERRUPTIBLE);
> >> >
> >> > if (kvm_vcpu_check_block(vcpu) < 0)
> >> > break;
> >> > @@ -2028,7 +2027,7 @@ void kvm_vcpu_block(struct kvm_vcpu *vcpu)
> >> > schedule();
> >> > }
> >> >
> >> > - finish_wait(&vcpu->wq, &wait);
> >> > + finish_swait(&vcpu->wq, &wait);
> >> > cur = ktime_get();
> >> >
> >> > out:
> > Should we not take this opportunity to get rid of these open-coded wait
> > loops?
>
> I find them way more readable than a 6-argument __wait_event...
I could introduce wait_event_idle_cmd() and be at 3 if you think that
helps.
#define __wait_event_idle_cmd(wq, cond, cmd) \
___wait_event(wq, cond, TASK_IDLE, 0, 0, cmd)
etc..
Its that awkward waited variable that makes it hard to use the 'regular'
2 parameter thing. Although you could of course do horrible things like:
__wait_event_idle(vcpu->wq, ({
bool done = kvm_cpu_check_block(vcpu) < 0;
if (!done)
waited = true;
done;
}));
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists