lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 27 Oct 2015 18:04:54 +0100
From:	Axel Haslam <ahaslam@...libre.com>
To:	Ulf Hansson <ulf.hansson@...aro.org>
Cc:	Kevin Hilman <khilman@...aro.org>,
	Lina Iyer <lina.iyer@...aro.org>, geert@...der.be,
	Krzysztof Kozłowski <k.kozlowski.k@...il.com>,
	"Rafael J. Wysocki" <rjw@...ysocki.net>,
	"linux-pm@...r.kernel.org" <linux-pm@...r.kernel.org>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	Benoit Cousson <bcousson@...libre.com>,
	Michael Turquette <mturquette@...libre.com>,
	Axel Haslam <ahaslam+renesas@...libre.com>
Subject: Re: [PATCH v10 1/6] PM / Domains: prepare for multiple states

Hi Ulf,

>
> Hi Axel,
>
> Apologize for the delay in providing feedback.
>

Thanks for the review!

>> ---
>>  arch/arm/mach-exynos/pm_domains.c     |  2 +-
>>  arch/arm/mach-imx/gpc.c               |  2 +-
>>  arch/arm/mach-s3c64xx/pm.c            |  4 ++--
>>  arch/arm/mach-shmobile/pm-rmobile.c   |  2 +-
>>  arch/arm/mach-ux500/pm_domains.c      |  2 +-
>>  arch/arm/mach-zx/zx296702-pm-domain.c |  2 +-
>
> You don't need to make above changes.
>
> Instead of inventing pm_genpd_init_simple(), I would rather see that
> you add a new __pm_genpd_init() API. Let's make it take *only* a
> "struct generic_pm_domain *genpd" parameter.
> Moreover, to prevent code duplication, adopt the code in
> pm_genpd_init() so it can invoke __pm_genpd_init().
>
> Then, piece by piece we can convert users from the legacy
> pm_genpd_init() to the __pm_genpd_init().

Ok, ill do that insted.

>>
>> +struct gpd_cpuidle_data {
>> +       unsigned int saved_exit_latency;
>> +       struct cpuidle_state *idle_state;
>> +};
>
> This is probably some leftover from an old version, right?

yes! this slipped by when i re-based to next, i should have
paid more attention. ill remove it.

>
>> +
>> +struct genpd_power_state {
>> +       char *name;
>
> I am wondering a bit about the char *name. Do we really need it and if
> so, what's do you intend to use it for?
>
>

The *name is allocated and used only when CONFIG_PM_ADVANCED_DEBUG
is enabled, its used to print the status on debugfs, when genpd_summary is read.

for example:

#cat /d/pm_genpd/summary
domain                          status          slaves
    /device                                             runtime status
----------------------------------------------------------------------
b3                              OFF
b2                              OFF
b1                              OFF              b2, b3
a3                              OFF
    /devices/platform/D2                                suspended
a4                              RET
    /devices/platform/D1                                suspended
a2                              RET              a4
a1                              RET              a2, a3
cpg_clocks                      on



Regards
Axel.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ