[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <201511081404.HGJ65681.LOSJFOtMFOVHFQ@I-love.SAKURA.ne.jp>
Date: Sun, 8 Nov 2015 14:04:46 +0900
From: Tetsuo Handa <penguin-kernel@...ove.SAKURA.ne.jp>
To: andy.shevchenko@...il.com, julia@...u.dk, joe@...ches.com
Cc: mhocko@...nel.org, linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] tree wide: Use kvfree() than conditional kfree()/vfree()
Andy Shevchenko wrote:
> Like Joe noticed you have left few places like
> void my_func_kvfree(arg)
> {
> kvfree(arg);
> }
>
> Might make sense to remove them completely, especially in case when
> you have changed the callers.
I think we should stop at
#define my_func_kvfree(arg) kvfree(arg)
in case someone want to add some code in future.
Also, we might want to add a helper that does vmalloc() when
kmalloc() failed because locations that do
ptr = kmalloc(size, GFP_NOFS);
if (!ptr)
ptr = vmalloc(size); /* Wrong because GFP_KERNEL is used implicitly */
are found.
> One more thought. Might be good to provide a coccinelle script for
> such places? Julia?
Welcome. I'm sure I'm missing some locations.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists