[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHp75Vc+J9hgGkdfQeZCQhbOMBdy-f8YfqxL8Z-gdXYPePfuzg@mail.gmail.com>
Date: Sun, 8 Nov 2015 22:11:31 +0200
From: Andy Shevchenko <andy.shevchenko@...il.com>
To: Tetsuo Handa <penguin-kernel@...ove.sakura.ne.jp>
Cc: Julia Lawall <julia@...u.dk>, Joe Perches <joe@...ches.com>,
mhocko@...nel.org, linux-mm@...ck.org,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] tree wide: Use kvfree() than conditional kfree()/vfree()
On Sun, Nov 8, 2015 at 7:04 AM, Tetsuo Handa
<penguin-kernel@...ove.sakura.ne.jp> wrote:
> Andy Shevchenko wrote:
>> Like Joe noticed you have left few places like
>> void my_func_kvfree(arg)
>> {
>> kvfree(arg);
>> }
>>
>> Might make sense to remove them completely, especially in case when
>> you have changed the callers.
>
> I think we should stop at
>
> #define my_func_kvfree(arg) kvfree(arg)
I don't think it's a good idea.
>
> in case someone want to add some code in future.
…then leave them to decide what to do, no? Trying to hunt the problem
which rather will not happen.
>
> Also, we might want to add a helper that does vmalloc() when
> kmalloc() failed because locations that do
>
> ptr = kmalloc(size, GFP_NOFS);
> if (!ptr)
> ptr = vmalloc(size); /* Wrong because GFP_KERNEL is used implicitly */
>
> are found.
Another patch like Sergey suggested.
>
>> One more thought. Might be good to provide a coccinelle script for
>> such places? Julia?
>
> Welcome. I'm sure I'm missing some locations.
--
With Best Regards,
Andy Shevchenko
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists