[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1447656686-4851-5-git-send-email-baiyaowei@cmss.chinamobile.com>
Date: Mon, 16 Nov 2015 14:51:23 +0800
From: Yaowei Bai <baiyaowei@...s.chinamobile.com>
To: akpm@...ux-foundation.org
Cc: bhe@...hat.com, dan.j.williams@...el.com,
dave.hansen@...ux.intel.com, dave@...olabs.net,
dhowells@...hat.com, dingel@...ux.vnet.ibm.com, hannes@...xchg.org,
hillf.zj@...baba-inc.com, holt@....com, iamjoonsoo.kim@....com,
joe@...ches.com, kuleshovmail@...il.com, mgorman@...e.de,
mhocko@...e.cz, mike.kravetz@...cle.com, n-horiguchi@...jp.nec.com,
penberg@...nel.org, rientjes@...gle.com, sasha.levin@...cle.com,
tj@...nel.org, tony.luck@...el.com, vbabka@...e.cz,
vdavydov@...allels.com, linux-mm@...ck.org,
linux-kernel@...r.kernel.org
Subject: [PATCH 4/7] mm/vmscan: page_is_file_cache can be boolean
This patch makes page_is_file_cache return bool to improve
readability due to this particular function only using either
one or zero as its return value.
No functional change.
Signed-off-by: Yaowei Bai <baiyaowei@...s.chinamobile.com>
---
include/linux/mm_inline.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/include/linux/mm_inline.h b/include/linux/mm_inline.h
index cf55945..af73135 100644
--- a/include/linux/mm_inline.h
+++ b/include/linux/mm_inline.h
@@ -8,8 +8,8 @@
* page_is_file_cache - should the page be on a file LRU or anon LRU?
* @page: the page to test
*
- * Returns 1 if @page is page cache page backed by a regular filesystem,
- * or 0 if @page is anonymous, tmpfs or otherwise ram or swap backed.
+ * Returns true if @page is page cache page backed by a regular filesystem,
+ * or false if @page is anonymous, tmpfs or otherwise ram or swap backed.
* Used by functions that manipulate the LRU lists, to sort a page
* onto the right LRU list.
*
@@ -17,7 +17,7 @@
* needs to survive until the page is last deleted from the LRU, which
* could be as far down as __page_cache_release.
*/
-static inline int page_is_file_cache(struct page *page)
+static inline bool page_is_file_cache(struct page *page)
{
return !PageSwapBacked(page);
}
--
1.9.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists