[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <35E9BBF7-3E75-4889-B8E3-67758754221F@redhat.com>
Date: Tue, 17 Nov 2015 22:04:24 +0800
From: "Yan, Zheng" <zyan@...hat.com>
To: Yaowei Bai <baiyaowei@...s.chinamobile.com>
Cc: Sage Weil <sage@...hat.com>, idryomov@...il.com,
ceph-devel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/2] fs/ceph: ceph_frag_contains_value can be boolean
> On Nov 17, 2015, at 14:52, Yaowei Bai <baiyaowei@...s.chinamobile.com> wrote:
>
> This patch makes ceph_frag_contains_value return bool to improve
> readability due to this particular function only using either one or
> zero as its return value.
>
> No functional change.
>
> Signed-off-by: Yaowei Bai <baiyaowei@...s.chinamobile.com>
> ---
> include/linux/ceph/ceph_frag.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/include/linux/ceph/ceph_frag.h b/include/linux/ceph/ceph_frag.h
> index 970ba5c..b827e06 100644
> --- a/include/linux/ceph/ceph_frag.h
> +++ b/include/linux/ceph/ceph_frag.h
> @@ -40,7 +40,7 @@ static inline __u32 ceph_frag_mask_shift(__u32 f)
> return 24 - ceph_frag_bits(f);
> }
>
> -static inline int ceph_frag_contains_value(__u32 f, __u32 v)
> +static inline bool ceph_frag_contains_value(__u32 f, __u32 v)
> {
> return (v & ceph_frag_mask(f)) == ceph_frag_value(f);
> }
> --
> 1.9.1
both applied
Thanks
Yan, Zheng
>
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists