[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20151123205743.GA18910@lst.de>
Date: Mon, 23 Nov 2015 21:57:43 +0100
From: Christoph Hellwig <hch@....de>
To: Jason Gunthorpe <jgunthorpe@...idianresearch.com>
Cc: Christoph Hellwig <hch@....de>, linux-rdma@...r.kernel.org,
sagig@....mellanox.co.il, bart.vanassche@...disk.com, axboe@...com,
linux-scsi@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/9] IB: add a proper completion queue abstraction
On Mon, Nov 23, 2015 at 01:01:36PM -0700, Jason Gunthorpe wrote:
> Okay, having now read the whole thing, I think I see the flow now. I don't
> see any holes in the above, other than it is doing a bit more work
> than it needs in some edges cases because it doesn't know if the CQ is
> actually empty or not.
>
> > > > + completed = __ib_process_cq(cq, IB_POLL_BUDGET_WORKQUEUE);
> > > > + if (completed >= IB_POLL_BUDGET_WORKQUEUE ||
> > > > + ib_req_notify_cq(cq, IB_POLL_FLAGS) > 0)
> > > > + queue_work(ib_comp_wq, &cq->work);
> > >
> > > Same comment here..
> >
> > Same here - we only requeue the work item if either we processed all of
> > our budget, or ib_req_notify_cq with IB_CQ_REPORT_MISSED_EVENTS told
> > us that we need to poll again.
>
> I find the if construction hard to read, but yes, it looks OK.
If you're got suggestions to improve the flow please send them my way.
I'm not entirely happy with it, but couldn't come up with a better idea.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists