lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 17 Dec 2015 17:36:52 +0300
From:	Sergei Shtylyov <sergei.shtylyov@...entembedded.com>
To:	Krzysztof Kozlowski <k.kozlowski@...sung.com>
Cc:	robh+dt@...nel.org, pawel.moll@....com, mark.rutland@....com,
	ijc+devicetree@...lion.org.uk, galak@...eaurora.org,
	myungjoo.ham@...sung.com, Chanwoo Choi <cw00.choi@...sung.com>,
	devicetree@...r.kernel.org, linux-kernel@...r.kernel.org,
	linux-sh@...r.kernel.org, linux-usb@...r.kernel.org
Subject: Re: [PATCH v3] extcon: add Maxim MAX3355 driver

Hello.

On 12/17/2015 3:53 AM, Krzysztof Kozlowski wrote:

>> Maxim Integrated MAX3355E chip integrates a charge pump and comparators to
>> enable a system with an integrated USB OTG dual-role transceiver to
>> function as an USB OTG dual-role device. In addition to sensing/controlling
>> Vbus, the chip also passes thru the ID signal from the USB OTG connector.
>> On some Renesas boards, this signal is just fed into the SoC thru a GPIO
>> pin -- there's no real OTG controller, only host and gadget USB controllers
>> sharing the same USB bus; however, we'd like to allow host or gadget
>> drivers to be loaded depending on the cable type, hence the need for the
>> MAX3355 extcon driver. The Vbus status signals are also wired to GPIOs
>> (however, we aren't currently interested in them), the OFFVBUS# signal is
>> controlled by the host controllers, there's also the SHDN# signal wired to
>> a GPIO, it should be driven high for the normal operation.
>>
>> Signed-off-by: Sergei Shtylyov <sergei.shtylyov@...entembedded.com>
>>
>> ---
>> Changes in version 3:
>> - reformatted the change log.
>>
>> Changes in version 2:
>> - added the USB gadget cable support;
>> - added the remove() driver method which drives SHDN# GPIO low to save power;
>> - dropped vendor prefix from the ID GPIO property name;
>> - changed the GPIO property name suffix to "-gpios";
>> - switched to usign extcon_set_cable_state_() API;
>> - switched to using the gpiod/sleeping 'gpiolib' APIs;
>> - addded error messages to max3355_probe();
>> - added IRQF_NO_SUSPEND flasg to the devm_request_threaded_irq() call;
>> - renamed 'ret' variable to 'err' in max3355_probe();
>> - expanded the Kconfig entry help text;
>> - added vendor name to the patch summary, the bindings document, the Kconfig
>>    entry, the driver heading comment, the module description, and the change log;
>> - fixed up and reformatted the change log.
>>
>>   Documentation/devicetree/bindings/extcon/extcon-max3355.txt |   21 +
>>   drivers/extcon/Kconfig                                      |    8
>>   drivers/extcon/Makefile                                     |    1
>>   drivers/extcon/extcon-max3355.c                             |  153 ++++++++++++
>>   4 files changed, 183 insertions(+)
>>
>> Index: renesas/Documentation/devicetree/bindings/extcon/extcon-max3355.txt
>> ===================================================================
>> --- /dev/null
>> +++ renesas/Documentation/devicetree/bindings/extcon/extcon-max3355.txt
>> @@ -0,0 +1,21 @@
>> +Maxim Integrated MAX3355 USB OTG chip
>> +-------------------------------------
>> +
>> +MAX3355 integrates a charge pump and comparators to enable a system with an
>> +integrated USB OTG dual-role transceiver to function as a USB OTG dual-role
>> +device.
>> +
>> +Required properties:
>> +- compatible: should be "maxim,max3355";
>> +- maxim,shdn-gpios: should contain a phandle and GPIO specifier for the GPIO pin
>> +  connected to the MAX3355's SHDN# pin;
>
> Could you add some indentation to the wrapped line for this property?
> For readability.

    If it's not indented enough, I can add more spaces/tabs.

>> +- id-gpios: should contain a phandle and GPIO specifier for the GPIO pin
>> +  connected to the MAX3355's ID_OUT pin.
>
> Ditto.
>
> Why this property lacks the vendor prefix i(n comparison to shdn-gpios
> which has the prefix)?

    Since the extcon-usb-gpio driver uses "id-gpio" prop already. I can add 
back the vendor prefix if you insist.

[...]
>> Index: renesas/drivers/extcon/extcon-max3355.c
>> ===================================================================
>> --- /dev/null
>> +++ renesas/drivers/extcon/extcon-max3355.c
>> @@ -0,0 +1,153 @@
[...]
>> +static int max3355_probe(struct platform_device *pdev)
>> +{
>> +       struct device_node *np = pdev->dev.of_node;
>> +       struct max3355_data *data;
>> +       struct gpio_desc *gpiod;
>> +       int irq, err;
>> +
>> +       data = devm_kzalloc(&pdev->dev, sizeof(struct max3355_data),
>> +                           GFP_KERNEL);
>> +       if (!data)
>> +               return -ENOMEM;
>> +
>> +       data->edev = devm_extcon_dev_allocate(&pdev->dev, max3355_cable);
>> +       if (IS_ERR(data->edev)) {
>> +               dev_err(&pdev->dev, "failed to allocate extcon device\n");
>> +               return PTR_ERR(data->edev);
>> +       }
>> +       data->edev->name = kstrdup(np->name, GFP_KERNEL);
>
> I think it is not needed any more (extcon_dev_register()) will set it.
> Anyway there is no checking for NULL return value and no freeing in
> error/exit paths.

    Oops, will fix.

[...]
>> +static struct platform_driver max3355_driver = {
>> +       .probe          = max3355_probe,
>> +       .remove         = max3355_remove,
>> +       .driver         = {
>> +               .name   = "extcon-max3355",
>> +               .of_match_table = max3355_match_table,
>> +               .owner  = THIS_MODULE,
>
> No need for owner.
> Please pass the source through recent coccicheck and fix the findings.

    Has it been included in the kernel source somewhere already?

> Best regards,
> Krzysztof

MBR, Sergei

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ