[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20151221085947-mutt-send-email-mst@redhat.com>
Date: Mon, 21 Dec 2015 09:10:52 +0200
From: "Michael S. Tsirkin" <mst@...hat.com>
To: Peter Zijlstra <peterz@...radead.org>
Cc: Andrew Cooper <andrew.cooper3@...rix.com>,
Jason Wang <jasowang@...hat.com>,
Rusty Russell <rusty@...tcorp.com.au>, qemu-devel@...gnu.org,
Alexander Duyck <alexander.duyck@...il.com>,
linux-kernel@...r.kernel.org,
David Vrabel <david.vrabel@...rix.com>,
xen-devel@...ts.xenproject.org,
Boris Ostrovsky <boris.ostrovsky@...cle.com>,
virtualization@...ts.linux-foundation.org,
Arnd Bergmann <arnd@...db.de>, linux-arch@...r.kernel.org
Subject: Re: [Xen-devel] new barrier type for paravirt (was Re: [PATCH]
virtio_ring: use smp_store_mb)
On Sun, Dec 20, 2015 at 08:59:44PM +0100, Peter Zijlstra wrote:
> On Sun, Dec 20, 2015 at 05:07:19PM +0000, Andrew Cooper wrote:
> >
> > Very much +1 for fixing this.
> >
> > Those names would be fine, but they do add yet another set of options in
> > an already-complicated area.
> >
> > An alternative might be to have the regular smp_{w,r,}mb() not revert
> > back to nops if CONFIG_PARAVIRT, or perhaps if pvops have detected a
> > non-native environment. (I don't know how feasible this suggestion is,
> > however.)
>
> So a regular SMP kernel emits the LOCK prefix and will patch it out with
> a DS prefix (iirc) when it finds but a single CPU. So for those you
> could easily do this.
>
> However an UP kernel will not emit the LOCK and do no patching.
>
> So if you're willing to make CONFIG_PARAVIRT depend on CONFIG_SMP or
> similar, this is doable.
One of the uses for virtio is to allow testing an existing kernel on
kvm just by loading a module, and this will break this usecase.
> I don't see people going to allow emitting the LOCK prefix (and growing
> the kernel text size) for UP kernels.
Thinking about this more, maybe __smp_*mb is a better set of names.
The nice thing about it is that we can then have generic code
that does basically
#ifdef CONFIG_SMP
#define smp_mb() __smp_mb()
#else
#define smp_mb() barrier()
#endif
and reuse this on all architectures.
So instead of a maintainance burden, we are actually
removing code duplication.
--
MST
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists