[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20160118134339.GA16263@IND12F0122>
Date: Mon, 18 Jan 2016 13:42:35 +0000
From: "Gujulan Elango, Hari Prasath (H.)" <hgujulan@...teon.com>
To: "gregkh@...uxfoundation.org" <gregkh@...uxfoundation.org>,
"johnny.kim@...el.com" <johnny.kim@...el.com>,
"austin.shin@...el.com" <austin.shin@...el.com>,
"chris.park@...el.com" <chris.park@...el.com>,
"tony.cho@...el.com" <tony.cho@...el.com>,
"glen.lee@...el.com" <glen.lee@...el.com>,
"leo.kim@...el.com" <leo.kim@...el.com>
CC: "devel@...verdev.osuosl.org" <devel@...verdev.osuosl.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-wireless@...r.kernel.org" <linux-wireless@...r.kernel.org>
Subject: [PATCH] staging: wilc1000: Move Macro definition
From: Hari Prasath Gujulan Elango <hgujulan@...teon.com>
This patch move's a macro defined in the middle of a structure
definition to make it more readable.
Signed-off-by: Hari Prasath Gujulan Elango <hgujulan@...teon.com>
---
drivers/staging/wilc1000/wilc_sdio.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/wilc_sdio.c b/drivers/staging/wilc1000/wilc_sdio.c
index e961b50..875ea68 100644
--- a/drivers/staging/wilc1000/wilc_sdio.c
+++ b/drivers/staging/wilc1000/wilc_sdio.c
@@ -29,12 +29,12 @@ static const struct sdio_device_id wilc_sdio_ids[] = {
};
#define WILC_SDIO_BLOCK_SIZE 512
+#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
typedef struct {
bool irq_gpio;
u32 block_size;
int nint;
-#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */
int has_thrpt_enh3;
} wilc_sdio_t;
--
1.9.1
Powered by blists - more mailing lists