lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:	Tue, 19 Jan 2016 14:21:40 -0700
From:	Jens Axboe <axboe@...com>
To:	<torvalds@...uxfoundation.org>
CC:	<linux-kernel@...r.kernel.org>, <linux-block@...r.kernel.org>
Subject: [GIT PULL] Core block IO changes for 4.5

Hi Linus,

We don't have a lot of core changes this time around, it's mostly in
drivers, which will come in a subsequent pull.

The cores changes include:

- blk-mq
        - Prep patch from Christoph, changing blk_mq_alloc_request() to
          take flags instead of just using gfp_t for sleep/nosleep.
        - Doc patch from me, clarifying the difference between legacy
          and blk-mq for timer usage.
        - Fixes from Raghavendra for memory-less numa nodes, and a reuse
          of CPU masks.

- Cleanup from Geliang Tang, using offset_in_page() instead of open
  coding it.

- From Ilya, rename request_queue slab to it reflects what it holds, and
  a fix for proper use of bdgrab/put.

- A real fix for the split across stripe boundaries from Keith. We
  yanked a broken version of this from 4.4-rc final, this one works.

- From Mike Krinkin, emit a trace message when we split.

- From Wei Tang, two small cleanups, not explicitly clearing memory that
  is already cleared.

Please pull!


  git://git.kernel.dk/linux-block.git for-4.5/core


----------------------------------------------------------------
Christoph Hellwig (1):
      blk-mq: add a flags parameter to blk_mq_alloc_request

Geliang Tang (1):
      bio: use offset_in_page macro

Ilya Dryomov (2):
      block: rename request_queue slab cache
      block: use bd{grab,put}() instead of open-coding

Jens Axboe (2):
      block: clarify blk_add_timer() use case for blk-mq
      Revert "blk-flush: Queue through IO scheduler when flush not required"

Keith Busch (1):
      block: split bios to max possible length

Mike Krinkin (1):
      block: add call to split trace point

Raghavendra K T (2):
      blk-mq: Reuse hardware context cpumask for tags
      blk-mq: Avoid memoryless numa node encoded in hctx numa_node

Wei Tang (2):
      block: do not initialise globals to 0 or NULL
      block: do not initialise statics to 0 or NULL

 block/bio.c                       |  4 ++--
 block/blk-core.c                  | 15 ++++++++-------
 block/blk-flush.c                 |  2 +-
 block/blk-merge.c                 | 22 +++++++++++++++++++---
 block/blk-mq-cpumap.c             |  2 +-
 block/blk-mq-tag.c                | 11 +++++------
 block/blk-mq.c                    | 31 ++++++++++---------------------
 block/blk-mq.h                    | 11 ++++-------
 block/blk-timeout.c               |  6 ++++++
 block/genhd.c                     |  2 +-
 drivers/block/mtip32xx/mtip32xx.c |  2 +-
 drivers/block/null_blk.c          |  2 +-
 drivers/char/raw.c                |  2 +-
 drivers/nvme/host/lightnvm.c      |  2 +-
 drivers/nvme/host/pci.c           | 11 ++++++-----
 fs/block_dev.c                    | 10 +++++-----
 include/linux/blk-mq.h            |  8 +++++++-
 include/linux/blkdev.h            |  2 +-
 18 files changed, 80 insertions(+), 65 deletions(-)

-- 
Jens Axboe

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ