lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 25 Jan 2016 12:35:44 +0100
From:	Jan Kara <jack@...e.cz>
To:	Mel Gorman <mgorman@...hsingularity.net>
Cc:	Andrew Morton <akpm@...ux-foundation.org>,
	Hugh Dickins <hughd@...gle.com>, Jan Kara <jack@...e.cz>,
	Linux-FSDevel <linux-fsdevel@...r.kernel.org>,
	Linux-MM <linux-mm@...ck.org>,
	LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/2] mm: filemap: Remove redundant code in
 do_read_cache_page

On Mon 25-01-16 10:03:23, Mel Gorman wrote:
> do_read_cache_page and __read_cache_page duplicates page filler code
> when filling the page for the first time. This patch simply removes the
> duplicate logic.
> 
> Signed-off-by: Mel Gorman <mgorman@...hsingularity.net>

Looks good to me. You can add:

Reviewed-by: Jan Kara <jack@...e.cz>

								Honza

> ---
>  mm/filemap.c | 43 ++++++++++++-------------------------------
>  1 file changed, 12 insertions(+), 31 deletions(-)
> 
> diff --git a/mm/filemap.c b/mm/filemap.c
> index bc943867d68c..aa38593d0cd5 100644
> --- a/mm/filemap.c
> +++ b/mm/filemap.c
> @@ -2283,7 +2283,7 @@ static struct page *wait_on_page_read(struct page *page)
>  	return page;
>  }
>  
> -static struct page *__read_cache_page(struct address_space *mapping,
> +static struct page *do_read_cache_page(struct address_space *mapping,
>  				pgoff_t index,
>  				int (*filler)(void *, struct page *),
>  				void *data,
> @@ -2305,31 +2305,19 @@ static struct page *__read_cache_page(struct address_space *mapping,
>  			/* Presumably ENOMEM for radix tree node */
>  			return ERR_PTR(err);
>  		}
> +
> +filler:
>  		err = filler(data, page);
>  		if (err < 0) {
>  			page_cache_release(page);
> -			page = ERR_PTR(err);
> -		} else {
> -			page = wait_on_page_read(page);
> +			return ERR_PTR(err);
>  		}
> -	}
> -	return page;
> -}
> -
> -static struct page *do_read_cache_page(struct address_space *mapping,
> -				pgoff_t index,
> -				int (*filler)(void *, struct page *),
> -				void *data,
> -				gfp_t gfp)
> -
> -{
> -	struct page *page;
> -	int err;
>  
> -retry:
> -	page = __read_cache_page(mapping, index, filler, data, gfp);
> -	if (IS_ERR(page))
> -		return page;
> +		page = wait_on_page_read(page);
> +		if (IS_ERR(page))
> +			return page;
> +		goto out;
> +	}
>  	if (PageUptodate(page))
>  		goto out;
>  
> @@ -2337,21 +2325,14 @@ static struct page *do_read_cache_page(struct address_space *mapping,
>  	if (!page->mapping) {
>  		unlock_page(page);
>  		page_cache_release(page);
> -		goto retry;
> +		goto repeat;
>  	}
>  	if (PageUptodate(page)) {
>  		unlock_page(page);
>  		goto out;
>  	}
> -	err = filler(data, page);
> -	if (err < 0) {
> -		page_cache_release(page);
> -		return ERR_PTR(err);
> -	} else {
> -		page = wait_on_page_read(page);
> -		if (IS_ERR(page))
> -			return page;
> -	}
> +	goto filler;
> +
>  out:
>  	mark_page_accessed(page);
>  	return page;
> -- 
> 2.6.4
> 
-- 
Jan Kara <jack@...e.com>
SUSE Labs, CR

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ