[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAPDyKFoS2q4-4KXQTZ9Ki54QNqJM6=itLFiH2koW3QFpmuuJfQ@mail.gmail.com>
Date: Wed, 27 Jan 2016 15:15:18 +0100
From: Ulf Hansson <ulf.hansson@...aro.org>
To: Geliang Tang <geliangtang@....com>
Cc: Rabin Vincent <rabin.vincent@...s.com>,
linux-mmc <linux-mmc@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 5/7] mmc: usdhi6rol0: use to_delayed_work
On 1 January 2016 at 15:59, Geliang Tang <geliangtang@....com> wrote:
> Use to_delayed_work() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@....com>
Thanks, applied for next.
Kind regards
Uffe
> ---
> drivers/mmc/host/usdhi6rol0.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/mmc/host/usdhi6rol0.c b/drivers/mmc/host/usdhi6rol0.c
> index b47122d..b2752fe 100644
> --- a/drivers/mmc/host/usdhi6rol0.c
> +++ b/drivers/mmc/host/usdhi6rol0.c
> @@ -1630,7 +1630,7 @@ static irqreturn_t usdhi6_cd(int irq, void *dev_id)
> */
> static void usdhi6_timeout_work(struct work_struct *work)
> {
> - struct delayed_work *d = container_of(work, struct delayed_work, work);
> + struct delayed_work *d = to_delayed_work(work);
> struct usdhi6_host *host = container_of(d, struct usdhi6_host, timeout_work);
> struct mmc_request *mrq = host->mrq;
> struct mmc_data *data = mrq ? mrq->data : NULL;
> --
> 2.5.0
>
>
Powered by blists - more mailing lists