lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Thu, 28 Jan 2016 22:57:07 +0100
From:	Arnd Bergmann <arnd@...db.de>
To:	linux-arm-kernel@...ts.infradead.org
Cc:	Russell King - ARM Linux <linux@....linux.org.uk>,
	Jouni Malinen <j@...fi>, netdev@...r.kernel.org,
	linux-wireless@...r.kernel.org, linux-kernel@...r.kernel.org,
	Kalle Valo <kvalo@...eaurora.org>
Subject: Re: [PATCH] hostap: avoid uninitialized variable use in hfa384x_get_rid

On Wednesday 27 January 2016 19:26:13 Russell King - ARM Linux wrote:
> On Wed, Jan 27, 2016 at 02:45:26PM +0100, Arnd Bergmann wrote:
> So, why give the compiler a hard time as you're doing, why make the code
> harder to read.  What's wrong with:
> 
>         spin_lock_bh(&local->baplock);
> 
>         res = hfa384x_setup_bap(dev, BAP0, rid, 0);
>         if (res)
>                 goto unlock;
> 
>         res = hfa384x_from_bap(dev, BAP0, &rec, sizeof(rec));
>         if (res)
>                 goto unlock;
> 
>         if (le16_to_cpu(rec.len) == 0) {
>                 /* RID not available */
>                 res = -ENODATA;
>                 goto unlock;
>         }
> 
>         rlen = (le16_to_cpu(rec.len) - 1) * 2;
>         if (exact_len && rlen != len) {
>                 printk(KERN_DEBUG "%s: hfa384x_get_rid - RID len mismatch: rid=0x%04x, len=%d (expected %d)\n",
>                        dev->name, rid, rlen, len);
>                 res = -ENODATA;
>                 goto unlock;
>         }
> 
>         res = hfa384x_from_bap(dev, BAP0, buf, len);
> unlock:
>         spin_unlock_bh(&local->baplock);
> 
> ?
> 

Good idea, I'll send a new version.

	Arnd

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ