[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20160206115945.43B2460495@smtp.codeaurora.org>
Date: Sat, 6 Feb 2016 11:59:45 +0000 (UTC)
From: Kalle Valo <kvalo@...eaurora.org>
To: Arnd Bergmann <arnd@...db.de>
Cc: Jouni Malinen <j@...fi>, netdev@...r.kernel.org,
linux-wireless@...r.kernel.org, Arnd Bergmann <arnd@...db.de>,
linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
Russell King - ARM Linux <linux@....linux.org.uk>
Subject: Re: [v2] hostap: avoid uninitialized variable use in hfa384x_get_rid
> The driver reads a value from hfa384x_from_bap(), which may fail,
> and then assigns the value to a local variable. gcc detects that
> in in the failure case, the 'rlen' variable now contains
> uninitialized data:
>
> In file included from ../drivers/net/wireless/intersil/hostap/hostap_pci.c:220:0:
> drivers/net/wireless/intersil/hostap/hostap_hw.c: In function 'hfa384x_get_rid':
> drivers/net/wireless/intersil/hostap/hostap_hw.c:842:5: warning: 'rec' may be used uninitialized in this function [-Wmaybe-uninitialized]
> if (le16_to_cpu(rec.len) == 0) {
>
> This restructures the function as suggested by Russell King, to
> make it more readable and get more reliable error handling, by
> handling each failure mode using a goto.
>
> Signed-off-by: Arnd Bergmann <arnd@...db.de>
Thanks, applied to wireless-drivers-next.git.
Kalle Valo
Powered by blists - more mailing lists