[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1454733014-15237-1-git-send-email-mcgrof@kernel.org>
Date: Fri, 5 Feb 2016 20:30:11 -0800
From: "Luis R. Rodriguez" <mcgrof@...nel.org>
To: hpa@...or.com, tglx@...utronix.de, mingo@...hat.com, bp@...en8.de
Cc: konrad.wilk@...cle.com, rusty@...tcorp.com.au, luto@...capital.net,
boris.ostrovsky@...cle.com, mcb30@...e.org, jgross@...e.com,
JBeulich@...e.com, joro@...tes.org, ryabinin.a.a@...il.com,
long.wanglong@...wei.com, qiuxishi@...wei.com,
aryabinin@...tuozzo.com, mchehab@....samsung.com, x86@...nel.org,
xen-devel@...ts.xensource.com, linux-kernel@...r.kernel.org,
"Luis R. Rodriguez" <mcgrof@...nel.org>
Subject: [PATCH v2 0/3] paravirt: rebrand paravirt_enabled as paravirt_legacy
There's been confusion both in code and by developers as to what
the paravirt_enabled thing means. This sets to clarify this to help
build stronger semantics on our bootup process.
This was originally suggested by Konrad and I included this as part of
a larger patch set [0]. I've decided to break that single rename patch (1/8)
out into a 3 smaller patches to both make it easier to review and to help
with regression testing, should any issues arise.
[0] http://lkml.kernel.org/r/1450217797-19295-1-git-send-email-mcgrof@do-not-panic.com
[1] http://lkml.kernel.org/r/1450217797-19295-2-git-send-email-mcgrof@do-not-panic.com
Luis R. Rodriguez (3):
paravirt: use bool for paravirt_enabled() and paravirt_has_feature()
paravirt: replace direct access to pv_info.paravirt_enabled
paravirt: rename paravirt_enabled to paravirt_legacy
arch/x86/entry/entry_32.S | 2 +-
arch/x86/include/asm/paravirt.h | 10 +++++-----
arch/x86/include/asm/paravirt_types.h | 35 +++++++++++++++++++++++++++++++++--
arch/x86/include/asm/processor.h | 4 ++--
arch/x86/kernel/apm_32.c | 2 +-
arch/x86/kernel/asm-offsets.c | 2 +-
arch/x86/kernel/cpu/intel.c | 2 +-
arch/x86/kernel/cpu/microcode/core.c | 2 +-
arch/x86/kernel/head.c | 2 +-
arch/x86/kernel/kvm.c | 9 +--------
arch/x86/kernel/paravirt.c | 2 +-
arch/x86/kernel/rtc.c | 2 +-
arch/x86/kernel/tboot.c | 2 +-
arch/x86/lguest/boot.c | 4 ++--
arch/x86/mm/dump_pagetables.c | 2 +-
arch/x86/xen/enlighten.c | 2 +-
drivers/pnp/pnpbios/core.c | 2 +-
17 files changed, 55 insertions(+), 31 deletions(-)
--
2.7.0
Powered by blists - more mailing lists