lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 10 Feb 2016 13:29:31 +0100
From:	Jiri Olsa <jolsa@...hat.com>
To:	Namhyung Kim <namhyung@...nel.org>
Cc:	Arnaldo Carvalho de Melo <acme@...nel.org>,
	Ingo Molnar <mingo@...nel.org>,
	Peter Zijlstra <peterz@...radead.org>,
	Jiri Olsa <jolsa@...nel.org>,
	LKML <linux-kernel@...r.kernel.org>,
	David Ahern <dsahern@...il.com>,
	Andi Kleen <andi@...stfloor.org>,
	Stephane Eranian <eranian@...gle.com>,
	Wang Nan <wangnan0@...wei.com>
Subject: Re: [PATCH 14/23] perf ui/stdio: Implement hierarchy output mode

On Wed, Feb 10, 2016 at 01:23:45PM +0100, Jiri Olsa wrote:
> On Fri, Feb 05, 2016 at 10:01:46PM +0900, Namhyung Kim wrote:
> 
> SNIP
> 
> >  
> > -	for (nd = rb_first(&hists->entries); nd; nd = rb_next(nd)) {
> > +	for (nd = rb_first(&hists->entries); nd; nd = rb_hierarchy_next(nd)) {
> >  		struct hist_entry *h = rb_entry(nd, struct hist_entry, rb_node);
> >  		float percent;
> >  
> > @@ -542,6 +614,9 @@ print_entries:
> >  						   MAP__FUNCTION, fp);
> >  			fprintf(fp, "%.10s end\n", graph_dotted_line);
> >  		}
> > +
> > +		if (symbol_conf.report_hierarchy)
> > +			h->unfolded = true;
> 
> what's this for?
> 

ah it's stdio, we need to show everything.. ok ;-)

I was thinking of putting this 'force un/fold' logic into the
rb_hierarchy_next interface, because it's also not nice in
hists__filter_hierarchy function..

maybe having extra argument telling the walk preference
would be easier to read, like:

  rb_hierarchy_next(&h->rb_node, FORCE_UNFOLD);
  rb_hierarchy_next(&h->rb_node, FORCE_FOLD);
  rb_hierarchy_next(&h->rb_node, DEFAULT);

with some better names of course

just an idea.. it might turn horrible as well ;-)

thanks,
jirka

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ