[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <56CF0E6A.2090204@emindsoft.com.cn>
Date: Thu, 25 Feb 2016 22:23:38 +0800
From: Chen Gang <chengang@...ndsoft.com.cn>
To: Michal Hocko <mhocko@...nel.org>
CC: trivial@...nel.org, akpm@...ux-foundation.org, vbabka@...e.cz,
rientjes@...gle.com, linux-kernel@...r.kernel.org,
hannes@...xchg.org, mgorman@...hsingularity.net,
vdavydov@...tuozzo.com, dan.j.williams@...el.com,
linux-mm@...ck.org
Subject: Re: [PATCH trivial] include/linux/gfp.h: Improve the coding styles
On 2/25/16 16:57, Michal Hocko wrote:
> On Thu 25-02-16 06:26:31, chengang@...ndsoft.com.cn wrote:
>>
>> Always notice about 80 columns, and the white space near '|'.
>>
>> Let the wrapped function parameters align as the same styles.
>>
>> Remove redundant statement "enum zone_type z;" in function gfp_zone.
>
> I do not think this is an improvement. The comment placement is just odd
> and artificially splitting the mask into more lines makes git grep
> harder to use.
>
Excuse me, I am not quite sure your meaning is the whole contents of the
patch is worthless, or only for the "comment placement"?
For the "comment placement" the common way is below, but still make git
grep harder:
-#define __GFP_MOVABLE ((__force gfp_t)___GFP_MOVABLE) /* ZONE_MOVABLE allowed */
+/* ZONE_MOVABLE allowed */
+#define __GFP_MOVABLE ((__force gfp_t)___GFP_MOVABLE)
Then how about:
-#define __GFP_MOVABLE ((__force gfp_t)___GFP_MOVABLE) /* ZONE_MOVABLE allowed */
+#define __GFP_MOVABLE \
((__force gfp_t)___GFP_MOVABLE) /* ZONE_MOVABLE allowed */
or:
-#define __GFP_MOVABLE ((__force gfp_t)___GFP_MOVABLE) /* ZONE_MOVABLE allowed */
+#define __GFP_MOVABLE /* ZONE_MOVABLE allowed */ \
((__force gfp_t)___GFP_MOVABLE)
Thanks.
--
Chen Gang (陈刚)
Managing Natural Environments is the Duty of Human Beings.
Powered by blists - more mailing lists