[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <56D8E74B.3010603@rock-chips.com>
Date: Fri, 4 Mar 2016 09:39:23 +0800
From: Shawn Lin <shawn.lin@...k-chips.com>
To: Jaehoon Chung <jh80.chung@...sung.com>,
Shawn Lin <shawn.lin@...k-chips.com>,
Adrian Hunter <adrian.hunter@...el.com>,
Ulf Hansson <ulf.hansson@...aro.org>
Cc: Michal Simek <michal.simek@...inx.com>, soren.brinkmann@...inx.com,
linux-mmc@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [RFC PATCH 1/4] mmc: core: add cap-enhanced-strobe support
Hi Jaehoon,
On 2016/3/3 20:08, Jaehoon Chung wrote:
> Hi Shawn,
>
> On 03/03/2016 11:36 AM, Shawn Lin wrote:
>> This patch introduce cap-enhanced-strobe for platforms which
>> want to enable enhanced strobe function from DT if the mmc host
>> controller claims to support enhanced strobe.
>
> I don't know why need to add the capability and property.
>
From my point, HS400-ES is a optional feature, so we should leave it
for people to decide whether to use it. Just as my controller supports
hs400, but I can't force all the people using my platform to use hs400?
That's why we add mmc-hs400-* in DT.
But maybe I can change the name to mmc-hs400es-* ?
[...]
>> #define MMC_CAP_DRIVER_TYPE_A (1 << 23) /* Host supports Driver Type A */
>> #define MMC_CAP_DRIVER_TYPE_C (1 << 24) /* Host supports Driver Type C */
>> #define MMC_CAP_DRIVER_TYPE_D (1 << 25) /* Host supports Driver Type D */
>> +#define MMC_CAP_ENHANCED_STROBE (1 << 20) /* Host supports enhanced strobe */
>
> Need to fix ordering.
yeah~~ good catch!
>
>> #define MMC_CAP_CMD23 (1 << 30) /* CMD23 supported. */
>> #define MMC_CAP_HW_RESET (1 << 31) /* Hardware reset */
>>
>> @@ -469,6 +470,11 @@ static inline int mmc_host_uhs(struct mmc_host *host)
>> MMC_CAP_UHS_DDR50);
>> }
>>
>> +static inline int mmc_host_enhanced_strobe(struct mmc_host *host)
>> +{
>> + return host->caps & MMC_CAP_ENHANCED_STROBE;
>> +}
>> +
>> static inline int mmc_host_packed_wr(struct mmc_host *host)
>> {
>> return host->caps2 & MMC_CAP2_PACKED_WR;
>>
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
>
--
Best Regards
Shawn Lin
Powered by blists - more mailing lists