lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 5 Mar 2016 09:41:47 -0800
From:	Greg KH <gregkh@...uxfoundation.org>
To:	Jörg-Volker Peetz <jvpeetz@....de>
Cc:	linux-kernel@...r.kernel.org,
	Andrew Morton <akpm@...ux-foundation.org>,
	torvalds@...ux-foundation.org, stable@...r.kernel.org, lwn@....net,
	Jiri Slaby <jslaby@...e.cz>,
	Alex Deucher <alexander.deucher@....com>
Subject: Re: Linux 4.4.4 [regression]

On Sat, Mar 05, 2016 at 11:48:45AM +0100, Jörg-Volker Peetz wrote:
> On my HP Pavilion dv7 with hybrid graphics (AMD HD 4200 - AMD 5400) X can't be
> started anymore. When trying to start X with "startx" Xorg freezes to an
> un-killable process before switching to a frame buffer. From another console I'm
> able to kill the xinit process which brings the first console back to the shell
> prompt. I can find nothing relevant in the logs.
> 
> The last few lines in Xorg.0.log are:
> 
> ...
> [    61.007] (==) ModulePath set to "/usr/lib/xorg/modules"
> [    61.007] (II) The server relies on udev to provide the list of input devices.
> 	If no devices become available, reconfigure udev or disable AutoAddDevices.
> [    61.007] (II) Loader magic: 0x5571980cbdc0
> [    61.008] (II) Module ABI versions:
> [    61.008] 	X.Org ANSI C Emulation: 0.4
> [    61.008] 	X.Org Video Driver: 20.0
> [    61.008] 	X.Org XInput driver : 22.1
> [    61.008] 	X.Org Server Extension : 9.0
> [    61.009] (++) using VT number 1
> 
> [    61.009] (EE) systemd-logind: failed to get session: The name
> org.freedesktop.login1 was not provided by any .service files
> [    61.010] (II) xfree86: Adding drm device (/dev/dri/card0)
> [    61.011] (II) xfree86: Adding drm device (/dev/dri/card1)
> 
> which are the same as with 4.4.3. There the log continues with
> 
>  [    65.782] (--) PCI:*(0:1:5:0) 1002:9712:103c:1443 rev 0, Mem @
> 0xd0000000/268435456, 0xf0400000/65536, 0xf0300000/1048576, I/O @ 0x00004000/256
> [    65.782] (--) PCI: (0:2:0:0) 1002:68e0:103c:1443 rev 0, Mem @
> 0xe0000000/268435456, 0xf0200000/131072, I/O @ 0x00003000/256, BIOS @
> 0x????????/131072
> [    65.782] (II) LoadModule: "glx"
> [    65.784] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
> [    65.801] (II) Module glx: vendor="X.Org Foundation"
> ...
> 
> I attach the config file.

Can you use 'git bisect' between 4.4.3 and 4.4.4 to track down the
offending patch?

thanks,

greg k-h

Powered by blists - more mailing lists