lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20160317032751.GA31052@kroah.com>
Date:	Wed, 16 Mar 2016 20:27:51 -0700
From:	Greg KH <gregkh@...uxfoundation.org>
To:	Gavin O'Leary <gavinoleary3@...il.com>
Cc:	sparmaintainer@...sys.com, devel@...verdev.osuosl.org,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH] staging: unisys: visornic: Made comments look nicer

On Wed, Mar 16, 2016 at 08:00:45PM -0700, Gavin O'Leary wrote:
> Made comments not break coding style guidlines and easier to read.
> 
> Signed-off-by: Gavin O'Leary <gavinoleary3@...il.com>
> ---
>  drivers/staging/unisys/visornic/visornic_main.c | 29 +++++++++++++++----------
>  1 file changed, 17 insertions(+), 12 deletions(-)
> 
> diff --git a/drivers/staging/unisys/visornic/visornic_main.c b/drivers/staging/unisys/visornic/visornic_main.c
> index 0519470..50ad44e 100644
> --- a/drivers/staging/unisys/visornic/visornic_main.c
> +++ b/drivers/staging/unisys/visornic/visornic_main.c
> @@ -1215,11 +1215,13 @@ visornic_rx(struct uiscmdrsp *cmdrsp)
>  					"repost_return failed");
>  			return rx_count;
>  		}
> -		/* length rcvd is greater than firstfrag in this skb rcv buf  */
> -		skb->tail += RCVPOST_BUF_SIZE;	/* amount in skb->data */
> -		skb->data_len = skb->len - RCVPOST_BUF_SIZE;	/* amount that
> -								   will be in
> -								   frag_list */
> +		/* length rcvd is greater than firstfrag in this skb rcv buf*/
> +

Why the blank line?

> +		/*amount in skb->data */

/* amount...

> +		skb->tail += RCVPOST_BUF_SIZE;
> +
> +		/* amount that will be in frag_list */
> +		skb->data_len = skb->len - RCVPOST_BUF_SIZE;
>  	} else {
>  		/* data fits in this skb - no chaining - do
>  		 * PRECAUTIONARY check
> @@ -1313,14 +1315,18 @@ visornic_rx(struct uiscmdrsp *cmdrsp)
>  						break;
>  					}
>  				}
> +
> +				/* accept packet, dest matches a multicast
> +				 * address
> +				 */

Not correct format :(

>  				if (found_mc)
> -					break;	/* accept packet, dest
> -						   matches a multicast
> -						   address */
> +					break;
>  			}
> +
> +		/* accept packet, dest matches a multicast address */

Why say it twice?

>  		} else if (skb->pkt_type == PACKET_HOST) {
> -			break;	/* accept packet, h_dest must match vnic
> -				   mac address */

You dropped this comment?

Please relax, take a day off, and don't rush this, there's nothing I can
do with any patches at the moment with the merge window being opened
until 2 weeks from now anyway.

greg k-h

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ