[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20160322160202.9647702367dabf86b003b168@linux-foundation.org>
Date: Tue, 22 Mar 2016 16:02:02 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Peter Zijlstra <peterz@...radead.org>
Cc: Michal Hocko <mhocko@...nel.org>, linux-mm@...ck.org,
LKML <linux-kernel@...r.kernel.org>,
Tetsuo Handa <penguin-kernel@...ove.SAKURA.ne.jp>,
David Rientjes <rientjes@...gle.com>,
Ingo Molnar <mingo@...e.hu>
Subject: Re: [PATCH 1/9] sched: add schedule_timeout_idle()
On Tue, 22 Mar 2016 13:23:45 +0100 Peter Zijlstra <peterz@...radead.org> wrote:
> On Tue, Mar 22, 2016 at 12:00:18PM +0100, Michal Hocko wrote:
>
> > extern signed long schedule_timeout_interruptible(signed long timeout);
> > extern signed long schedule_timeout_killable(signed long timeout);
> > extern signed long schedule_timeout_uninterruptible(signed long timeout);
> > +extern signed long schedule_timeout_idle(signed long timeout);
>
> > +/*
> > + * Like schedule_timeout_uninterruptible(), except this task will not contribute
> > + * to load average.
> > + */
> > +signed long __sched schedule_timeout_idle(signed long timeout)
> > +{
> > + __set_current_state(TASK_IDLE);
> > + return schedule_timeout(timeout);
> > +}
> > +EXPORT_SYMBOL(schedule_timeout_idle);
>
> Yes we have 3 such other wrappers, but I've gotta ask: why? They seem
> pretty pointless.
I like the wrappers. At least, more than having to read the open-coded
version. The latter is just more stuff to interpret and to check
whereas I can look at "schedule_timeout_idle" and think "yup, I know
what that does".
But whatever. I'll probably be sending this series up for 4.6 and we can
worry about the schedule_timeout_foo() stuff later.
Powered by blists - more mailing lists