[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1458703028.22080.7.camel@perches.com>
Date: Tue, 22 Mar 2016 20:17:08 -0700
From: Joe Perches <joe@...ches.com>
To: Yaowei Bai <baiyaowei@...s.chinamobile.com>,
akpm@...ux-foundation.org
Cc: n-horiguchi@...jp.nec.com, kirill.shutemov@...ux.intel.com,
rientjes@...gle.com, iamjoonsoo.kim@....com, hannes@...xchg.org,
vdavydov@...tuozzo.com, kuleshovmail@...il.com, vbabka@...e.cz,
mgorman@...hsingularity.net, linux-mm@...ck.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 4/5] mm/lru: is_file/active_lru can be boolean
On Wed, 2016-03-23 at 10:26 +0800, Yaowei Bai wrote:
> This patch makes is_file/active_lru return bool to improve
> readability due to these particular functions only using either
> one or zero as their return value.
>
> No functional change.
These assignments to int should likely be modified too
$ git grep -w -n is_file_lru
include/linux/mmzone.h:191:static inline int is_file_lru(enum lru_list lru)
mm/vmscan.c:1404: nr_taken, mode, is_file_lru(lru));
mm/vmscan.c:1525: int file = is_file_lru(lru);
mm/vmscan.c:1581: int file = is_file_lru(lru);
mm/vmscan.c:1783: int file = is_file_lru(lru);
mm/vmscan.c:1934: if (is_file_lru(lru))
mm/vmscan.c:2129: int file = is_file_lru(lru);
Powered by blists - more mailing lists