[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5715462F.6090303@amd.com>
Date: Mon, 18 Apr 2016 15:40:15 -0500
From: Suravee Suthikulpanit <Suravee.Suthikulpanit@....com>
To: Radim Krčmář <rkrcmar@...hat.com>
CC: <pbonzini@...hat.com>, <joro@...tes.org>, <bp@...en8.de>,
<gleb@...nel.org>, <alex.williamson@...hat.com>,
<kvm@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<wei@...hat.com>, <sherry.hurwitz@....com>
Subject: Re: [PART1 RFC v4 02/11] KVM: x86: Introducing kvm_x86_ops VM
init/uninit hooks
Radim,
On 04/12/2016 03:49 AM, Radim Krčmář wrote:
> 2016-04-07 03:20-0500, Suravee Suthikulpanit:
>> Adding function pointers in struct kvm_x86_ops for processor-specific
>> layer to provide hooks for when KVM initialize and un-initialize VM.
>>
>> Signed-off-by: Suravee Suthikulpanit <suravee.suthikulpanit@....com>
>> ---
>> diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c
>> @@ -7781,6 +7784,9 @@ static void kvm_free_vcpus(struct kvm *kvm)
>> kvm_for_each_vcpu(i, vcpu, kvm)
>> kvm_arch_vcpu_free(vcpu);
>>
>> + if (kvm_x86_ops->vm_uninit)
>> + kvm_x86_ops->vm_uninit(kvm);
>
> vm_uninit() doesn't seem to have much to do with kvm_free_vcpus(),
> please call it from kvm_arch_destroy_vm().
>
> (kvm_x86_ops.vm_destroy would be a better name then.)
>
Okay. I'll rename this and move the hook to be called from
kvm_arch_destroy_vm().
Thanks,
Suravee
Powered by blists - more mailing lists