[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <57182E46.4040209@gmail.com>
Date: Thu, 21 Apr 2016 10:35:02 +0900
From: Taeung Song <treeze.taeung@...il.com>
To: Namhyung Kim <namhyung@...nel.org>
Cc: Arnaldo Carvalho de Melo <acme@...nel.org>,
linux-kernel@...r.kernel.org, Jiri Olsa <jolsa@...nel.org>,
Ingo Molnar <mingo@...nel.org>,
Peter Zijlstra <peterz@...radead.org>,
Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
Masami Hiramatsu <mhiramat@...nel.org>
Subject: Re: [RFC][PATCH v9 0/2] Infrastructure code for perf-config
Good morning, Namhyung :-)
On 04/21/2016 10:27 AM, Namhyung Kim wrote:
> On Thu, Apr 21, 2016 at 02:42:35AM +0900, Taeung Song wrote:
>> Hi,
>>
>> We can use the config files (i.e user wide ~/.perfconfig
>> and system wide $(sysconfdir)/perfconfig)
>> to configure perf tools. perf-config help user
>> manage the config files, not manually look into or edit them.
>>
>> Introduce new infrastructure code for config
>> management features of perf-config subcommand.
>>
>> This pathset contains basic code for various purposes of configuration management
>> showing current configs, in the near future,
>> showing all configs with default value,
>> getting current configs from the config files
>> or writing configs that user type on the config files, etc.
>>
>> IMHO, I think this infrastructure code is needed
>> to add new funcationalities for config management of perf-config.
>>
>> If anyone reviews this, I'd appreciate it.
>
> For both patches,
>
> Acked-by: Namhyung Kim <namhyung@...nel.org>
>
Thank you!!
Taeung
>>
>> v9:
>> - don't use the arbitrary maximum 'MAX_CONFIGS' (Arnaldo, Namhyung)
>> - change two-dimensinal arrays 'default_config_items' to array of pointers (Namhyung)
>> - remove needless 'enum perf_config_secion_idx'
>> - add sections 'intel-pt','convert' and their items
>> - modify perf_config_set__init() in accordance with new default config sections and items
>> - (applied two previous patches 860b8d4 and 20105ca from this patchset)
>>
>> v8:
>> - rebased onto the current acme/perf/core
>>
>> v7:
>> - rename 'is_custom' to 'is_allocated' to be proper (Masami)
>> - fix the code about free() or zfree() in perf_config_*__delete() (Masami)
>> - check set == NULL or not in show_config() (Masami)
>>
>> v6:
>> - don't use goto in add_config_item() (Masami)
>>
>> v5:
>> - departmentalize perf_config_set__delete() (Arnaldo)
>> - remove confusing find_config() (Arnaldo)
>> - use pr_debug() instead of pr_err() (Arnaldo)
>> - use zfree() instead of free() (Arnaldo)
>> - more compact in perf_config_set__new() (Arnaldo)
>> - rename variables 'perf_configs', 'config_items', etc. (Arnaldo)
>>
>> v4:
>> - fill perf_config_set__delete() in collect_config() for state of error
>> - fill the code setting is_custom value in add_config_item() (Namhyung)
>>
>> v3:
>> - use the section list that contains configs each section
>> instead of the single config list (Namhyung)
>> - exclude a patch for '--list-all' option from this patchset
>>
>> v2:
>> - remove perf_config_kind (user, system or both config files)
>> and needless at this time, etc. (Namhyung)
>> - separate this patch as several patches (Namhyung)
>> - fix typing errors, etc.
>>
>> Taeung Song (2):
>> perf config: Prepare all default configs
>> perf config: Initialize perf_config_set with all default configs
>>
>> tools/perf/builtin-config.c | 11 ++-
>> tools/perf/util/config.c | 187 ++++++++++++++++++++++++++++++++++++++++++--
>> tools/perf/util/config.h | 51 +++++++++++-
>> 3 files changed, 238 insertions(+), 11 deletions(-)
>>
>> --
>> 2.5.0
>>
Powered by blists - more mailing lists