lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 21 Apr 2016 17:48:40 +0100
From:	Will Deacon <will.deacon@....com>
To:	Mark Rutland <mark.rutland@....com>
Cc:	linux-efi@...r.kernel.org, ard.biesheuvel@...aro.org,
	catalin.marinas@....com, hpa@...or.com, leif.lindholm@...aro.org,
	linux@....linux.org.uk, matt@...eblueprint.co.uk, mingo@...hat.com,
	tglx@...utronix.de, linux-arm-kernel@...ts.infradead.org,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCHv2 2/5] arm64/efi: move to generic {__,}efi_call_virt

On Thu, Apr 21, 2016 at 12:35:26PM +0100, Mark Rutland wrote:
> Now there's a common template for {__,}efi_call_virt, remove the
> duplicate logic from the arm64 efi code.
> 
> Signed-off-by: Mark Rutland <mark.rutland@....com>
> Cc: Ard Biesheuvel <ard.biesheuvel@...aro.org>
> Cc: Catalin Marinas <catalin.marinas@....com>
> Cc: Leif Lindholm <leif.lindholm@...aro.org>
> Cc: Matt Fleming <matt@...eblueprint.co.uk>
> Cc: Will Deacon <will.deacon@....com>
> Cc: linux-arm-kernel@...ts.infradead.org
> Cc: linux-efi@...r.kernel.org
> Cc: linux-kernel@...r.kernel.org
> ---
>  arch/arm64/include/asm/efi.h | 21 +++++++--------------
>  1 file changed, 7 insertions(+), 14 deletions(-)
> 
> diff --git a/arch/arm64/include/asm/efi.h b/arch/arm64/include/asm/efi.h
> index 8e88a69..f4f71224 100644
> --- a/arch/arm64/include/asm/efi.h
> +++ b/arch/arm64/include/asm/efi.h
> @@ -14,28 +14,21 @@ extern void efi_init(void);
>  
>  int efi_create_mapping(struct mm_struct *mm, efi_memory_desc_t *md);
>  
> -#define efi_call_virt(f, ...)						\
> +#define arch_efi_call_virt_setup()					\
>  ({									\
> -	efi_##f##_t *__f;						\
> -	efi_status_t __s;						\
> -									\
>  	kernel_neon_begin();						\
>  	efi_virtmap_load();						\
> -	__f = efi.systab->runtime->f;					\
> -	__s = __f(__VA_ARGS__);						\
> -	efi_virtmap_unload();						\
> -	kernel_neon_end();						\
> -	__s;								\
>  })
>  
> -#define __efi_call_virt(f, ...)						\
> +#define arch_efi_call_virt(f, args...)					\
>  ({									\
>  	efi_##f##_t *__f;						\
> -									\
> -	kernel_neon_begin();						\
> -	efi_virtmap_load();						\
>  	__f = efi.systab->runtime->f;					\
> -	__f(__VA_ARGS__);						\
> +	__f(args);							\

Any reason to change this to a named argument? This patch is hard enough
to review as it is, given the way the diff has been generated!

Either way:

Acked-by: Will Deacon <will.deacon@....com>

Will

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ