[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1462218865.27137.18.camel@hpe.com>
Date: Mon, 02 May 2016 13:54:25 -0600
From: Toshi Kani <toshi.kani@....com>
To: Ross Zwisler <ross.zwisler@...ux.intel.com>
Cc: dan.j.williams@...el.com, jack@...e.cz, david@...morbit.com,
hch@...radead.org, boaz@...xistor.com, tytso@....edu,
adilger.kernel@...ger.ca, micah.parrish@....com,
linux-nvdimm@...ts.01.org, linux-fsdevel@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 3/3] xfs: Add alignment check for DAX mount
On Mon, 2016-05-02 at 13:50 -0600, Ross Zwisler wrote:
> On Mon, May 02, 2016 at 12:42:58PM -0600, Toshi Kani wrote:
:
> > xfs_warn(mp,
> > - "DAX enabled. Warning: EXPERIMENTAL, use at your own risk");
> > + "DAX enabled. Warning: EXPERIMENTAL, use at your own
> > risk");
> > if (sb->s_blocksize != PAGE_SIZE) {
> > xfs_alert(mp,
> > "Filesystem block size invalid for DAX Turning DAX
> > off.");
> > mp->m_flags &= ~XFS_MOUNT_DAX;
> > - } else if (!sb->s_bdev->bd_disk->fops->direct_access)
> > {
> > - xfs_alert(mp,
> > - "Block device does not support DAX Turning DAX off.");
> > + } else if ((error = bdev_direct_access(sb->s_bdev,
> > &dax)) < 0) {
> > + switch (error) {
> > + case -EOPNOTSUPP:
> > + xfs_alert(mp,
> > + "Block device does not support DAX Turning DAX
> > off.");
>
> Since you're already in here editing all the strings, can you add a
> period to make it more readable? Applies to all strings.
Right. Will do.
> >
> > + "Block device does not support DAX. Turning
> > DAX off.");
> ^
>
> >
> > + break;
> > + case -EINVAL:
> > + xfs_alert(mp,
> > + "Partition alignment invalid for DAX Turning
> > DAX off.");
> > + break;
> > + default:
> > + xfs_alert(mp,
> > + "DAX access failed (%d) DAX Turning DAX off.",
> > error);
>
> I DAX think you might DAX have too many DAXes in here. :)
Oops! :)
> >
> > + }
> > mp->m_flags &= ~XFS_MOUNT_DAX;
> > }
> > }
>
> Other than the nit-picking about the strings, this seems fine.
>
> You can add this for the series:
> Reviewed-by: Ross Zwisler <ross.zwisler@...ux.intel.com>
Thanks!
-Toshi
Powered by blists - more mailing lists