lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Tue, 10 May 2016 09:48:35 +0800
From:	Baoquan He <bhe@...hat.com>
To:	Corey Minyard <minyard@....org>
Cc:	kexec@...ts.infradead.org, linux-kernel@...r.kernel.org,
	Vivek Goyal <vgoyal@...hat.com>,
	Haren Myneni <hbabu@...ibm.com>,
	Corey Minyard <cminyard@...sta.com>, dyoung@...hat.com
Subject: Re: [PATCH] kdump: Fix gdb macros work work with newer and 64-bit
 kernels

Hi Corey,

On 05/09/16 at 07:10am, Corey Minyard wrote:
> >>>diff --git a/Documentation/kdump/gdbmacros.txt b/Documentation/kdump/gdbmacros.txt
> >>>index 9b9b454..e5bbd8d 100644
> >>>--- a/Documentation/kdump/gdbmacros.txt
> >>>+++ b/Documentation/kdump/gdbmacros.txt
> >>>@@ -54,42 +54,43 @@ document bttnobp
> >>>  	dump all thread stack traces on a kernel compiled with !CONFIG_FRAME_POINTER
> >>>  end
> >>>+define btthreadstruct
> >This is a nice wrapping, but I guess you want to name it as
> >btthreadstack, right? Since I didn't get at all why it's related to
> >thread_struct except of getting 'sp'.
> >
> 
> The name is based on what is passed into the function.  You do a
> backtrace when given a thread structure.  In my experience it is
> best to name functions based upon how the function's user sees it.
> Though I'm not stuck on the name, if you would prefer btthreadstack.

About the name, in fact a task struct is passed in. Mainly there's a
thread_struct defined in x86 ARCH, I thought you are handling
thread_struct related things when I look at the first glance.
btthreadstack is far better name that that, I like it.

******************************
arch/x86/include/asm/processor.h
struct thread_struct {         
        /* Cached TLS descriptors: */   
        struct desc_struct      tls_array[GDT_ENTRY_TLS_ENTRIES];
        unsigned long           sp0;    
        unsigned long           sp;     
#ifdef CONFIG_X86_32           
        unsigned long           sysenter_cs;
#else
......
}

Thanks
Baoquan

> 
> >>>+	set var $pid_task = $arg0
> >>>+
> >>>+	printf "\npid %d; comm %s:\n", $pid_task.pid, $pid_task.comm
> >>>+	printf "task struct: "
> >>>+	print $pid_task
> >>>+	printf "===================\n"
> >>>+	set var $stackp = $pid_task.thread.sp
> >>>+	set var $stack_top = ($stackp & ~4095) + 4096
> >>>+	set var $stack_bot = ($stackp & ~4095)
> >>>+
> >>>+	set $stackp = *((unsigned long *) $stackp)
> >>>+	while (($stackp < $stack_top) && ($stackp > $stack_bot))
> >>>+		set var $addr = *(((unsigned long *) $stackp) + 1)
> >>>+		info symbol $addr
> >>>+		set $stackp = *((unsigned long *) $stackp)
> >>>+	end
> >>>+end
> >>>+document btthreadstruct
> >>>+	 dump a thread stack using the given task structure pointer
> >>>+end

Powered by blists - more mailing lists