[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1463042948-12205-1-git-send-email-m.othacehe@gmail.com>
Date: Thu, 12 May 2016 10:48:32 +0200
From: Mathieu OTHACEHE <m.othacehe@...il.com>
To: johan@...nel.org
Cc: gregkh@...uxfoundation.org, linux-usb@...r.kernel.org,
linux-kernel@...r.kernel.org,
Mathieu OTHACEHE <m.othacehe@...il.com>
Subject: [PATCH 00/36] usb: serial: ti_usb_3410_5052: clean driver
Hi,
The now reverted mxu11x0 turned out to be a copy of ti_usb_3410_5052 driver.
This aim of this serie is to apply all of the cleanups we did in mxu11x0 to
ti_usb_3410_5052.
Thank you,
Mathieu
Mathieu OTHACEHE (36):
usb: serial: ti_usb_3410_5052: Remove useless comments
usb: serial: ti_usb_3410_5052: use __packed instead of
__attribute__((packed))
usb: serial: ti_usb_3410_5052: Remove ti_usb_3410_5052.h
usb: serial: ti_usb_3410_5052: Use inline functions rather than macro
usb: serial: ti_usb_3410_5052: Remove unused data structures
usb: serial: ti_usb_3410_5052: Do not use __uX types
usb: serial: ti_usb_3410_5052: Remove closing_wait module parameter
usb: serial: ti_usb_3410_5052: Remove useless dev_dbg messages
usb: serial: ti_usb_3410_5052: Use kzalloc instead of kmalloc
usb: serial: ti_usb_3410_5052: Remove useless NULL-testing
usb: serial: ti_usb_3410_5052: Use C_X macros instead of c_cflag
manipulation
usb: serial: ti_usb_3410_5052: Use generic read/write callbacks
usb: serial: ti_usb_3410_5052: Remove unused variables
usb: serial: ti_usb_3410_5052: Use macros instead of magic values
usb: serial: ti_usb_3410_5052: Remove in_sync and out_sync functions
usb: serial: ti_usb_3410_5052: Use bulk_out_size in TIOCGSERIAL
usb: serial: ti_usb_3410_5052: Remove useless tty_wakeup
usb: serial: ti_usb_3410_5052: Change ti_write_byte function arguments
usb: serial: ti_usb_3410_5052: Do not modify interrupt context
usb: serial: ti_usb_3410_5052: Remove usb_serial pointer in ti_port
usb: serial: ti_usb_3410_5052: Use generic close function
usb: serial: ti_usb_3410_5052: Change ti_get/set_serial_info function
arguments
usb: serial: ti_usb_3410_5052: Do not set shadow mcr in open callback
usb: serial: ti_usb_3410_5052: Use usb_serial_generic_open
usb: serial: ti_usb_3410_5052: Check old_termios parameter in
set_termios
usb: serial: ti_usb_3410_5052: Fix firmware downloading
usb: serial: ti_usb_3410_5052: Standardize debug and error messages
usb: serial: ti_usb_3410_5052: Use variables for vendor and product
usb: serial: ti_usb_3410_5052: Set shadow msr before waking up waiters
usb: serial: ti_usb_3410_5052: Remove backpointer in ti_port
usb: serial: ti_usb_3410_5052: Use a mutex to protect shadow mcr
usb: serial: ti_usb_3410_5052: Remove prefixes from private structures
usb: serial: ti_usb_3410_5052: Add CMSPAR support
usb: serial: ti_usb_3410_5052: Fix indentation problems
usb: serial: ti_usb_3410_5052: Remove function prototypes
usb: serial: ti_usb_3410_5052: Add myself as an author
drivers/usb/serial/ti_usb_3410_5052.c | 2055 +++++++++++++++------------------
drivers/usb/serial/ti_usb_3410_5052.h | 14 +-
2 files changed, 937 insertions(+), 1132 deletions(-)
--
2.8.2
Powered by blists - more mailing lists