lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 16 May 2016 19:52:31 +0300
From:	Pantelis Antoniou <pantelis.antoniou@...sulko.com>
To:	Rob Herring <robherring2@...il.com>
Cc:	Frank Rowand <frowand.list@...il.com>,
	Matt Porter <mporter@...sulko.com>,
	Grant Likely <grant.likely@...retlab.ca>,
	Koen Kooi <koen@...inion.thruhere.net>,
	Guenter Roeck <linux@...ck-us.net>,
	Marek Vasut <marex@...x.de>,
	Geert Uytterhoeven <geert@...ux-m68k.org>,
	devicetree@...r.kernel.org, linux-kernel@...r.kernel.org,
	Pantelis Antoniou <pantelis.antoniou@...sulko.com>,
	Pantelis Antoniou <panto@...oniou-consulting.com>
Subject: [PATCH v2 0/5] of: generic infrastructure fixes

The first patch renames the *_node_sysfs methods to _node_post since
this is more accurate when more work takes place besides sysfs
tweaking when the next patch is using a hashtable for phandles.
This is a win for very large blobs with a large number of phandles.
Current we use an exhaustive search which is not optimal at all.

The third patch adds a unittest/benchmark for hashed phandles
along with figures about performance.

A long standing request of applied overlays populating
the symbol list is implemented; this allows staggered overlay
application with a symbol from a previous overlay being used
by another after it.

Finally a pr_fmt for the overlay files is used for
uncluttering the printout a bit.

Changes since v1:
* Reworked phandle hash according to maintainer requests
* Added unittest/benchmark for phandle hash
* Reworked the overlay symbol patch
* Added pr_fmt patch


Pantelis Antoniou (5):
  of: rename *_node_sysfs to _node_post
  of: Support hashtable lookups for phandles
  of: unittest: hashed phandles unitest
  of: overlay: Pick up label symbols from overlays.
  of: overlay: Add pr_fmt for clarity

 drivers/of/base.c       |  45 +++++++++++--
 drivers/of/dynamic.c    |  18 +++--
 drivers/of/of_private.h |  37 ++++++++++-
 drivers/of/overlay.c    | 173 ++++++++++++++++++++++++++++++++++++------------
 drivers/of/unittest.c   |  72 +++++++++++++++++++-
 include/linux/of.h      |   2 +
 6 files changed, 289 insertions(+), 58 deletions(-)

-- 
1.7.12

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ