lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 23 May 2016 13:39:06 +0200
From:	Hans Verkuil <hverkuil@...all.nl>
To:	Shuah Khan <shuahkh@....samsung.com>, mchehab@....samsung.com,
	laurent.pinchart@...asonboard.com, sakari.ailus@....fi,
	hans.verkuil@...co.com, chehabrafael@...il.com,
	javier@....samsung.com, inki.dae@...sung.com,
	g.liakhovetski@....de, jh1009.sung@...sung.com
Cc:	linux-media@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/3] media: add media_device_unregister_put() interface

On 05/13/2016 07:09 PM, Shuah Khan wrote:
> Add media_device_unregister_put() interface to release reference to a media
> device allocated using the Media Device Allocator API. The media device is
> unregistered and freed when the last driver that holds the reference to the
> media device releases the reference. The media device is unregistered and
> freed in the kref put handler.
> 
> Signed-off-by: Shuah Khan <shuahkh@....samsung.com>
> ---
>  drivers/media/media-device.c | 11 +++++++++++
>  include/media/media-device.h | 15 +++++++++++++++
>  2 files changed, 26 insertions(+)
> 
> diff --git a/drivers/media/media-device.c b/drivers/media/media-device.c
> index 33a9952..b5c279a 100644
> --- a/drivers/media/media-device.c
> +++ b/drivers/media/media-device.c
> @@ -36,6 +36,7 @@
>  #include <media/media-device.h>
>  #include <media/media-devnode.h>
>  #include <media/media-entity.h>
> +#include <media/media-dev-allocator.h>
>  
>  #ifdef CONFIG_MEDIA_CONTROLLER
>  
> @@ -818,6 +819,16 @@ void media_device_unregister(struct media_device *mdev)
>  }
>  EXPORT_SYMBOL_GPL(media_device_unregister);
>  
> +void media_device_unregister_put(struct media_device *mdev)
> +{
> +	if (mdev == NULL)
> +		return;
> +
> +	dev_dbg(mdev->dev, "%s: mdev %p\n", __func__, mdev);
> +	media_device_put(mdev);
> +}
> +EXPORT_SYMBOL_GPL(media_device_unregister_put);
> +

I don't really see the need for a new unregister_put function. The only thing
it adds compared to media_device_put is the 'if (mdev == NULL)' check.

Is that check needed at all?

I would probably go for an API like this:

<brainstorm mode on>

/* Not sure if there should be a void *priv as the last argument */
int (*mdev_init_fnc)(struct media_device *mdev, struct device *dev);

/* Perhaps a void *priv is needed to pass to mdev_init_fnc?
   The callback is there to initialize the media_device and it's called
   with the lock held.
*/
struct media_device *media_device_allocate(struct device *dev, mdev_init_fnc fnc);

/* Helper function for usb devices */
struct media_device *media_device_usb_allocate(struct usb_device *udev,
					       char *driver_name);

/* counterpart of media_device_allocate, that makes more sense than allocate/put IMHO */
void media_device_release(struct media_device *mdev);

<brainstorm mode off>

Regards,

	Hans

>  static void media_device_release_devres(struct device *dev, void *res)
>  {
>  }
> diff --git a/include/media/media-device.h b/include/media/media-device.h
> index f743ae2..8bd836e 100644
> --- a/include/media/media-device.h
> +++ b/include/media/media-device.h
> @@ -499,6 +499,18 @@ int __must_check __media_device_register(struct media_device *mdev,
>  void media_device_unregister(struct media_device *mdev);
>  
>  /**
> + * media_device_unregister_put() - Unregisters a media device element
> + *
> + * @mdev:	pointer to struct &media_device
> + *
> + * Should be called to unregister media device allocated with Media Device
> + * Allocator API media_device_get() interface.
> + * It is safe to call this function on an unregistered (but initialised)
> + * media device.
> + */
> +void media_device_unregister_put(struct media_device *mdev);
> +
> +/**
>   * media_device_register_entity() - registers a media entity inside a
>   *	previously registered media device.
>   *
> @@ -658,6 +670,9 @@ static inline int media_device_register(struct media_device *mdev)
>  static inline void media_device_unregister(struct media_device *mdev)
>  {
>  }
> +static inline void media_device_unregister_put(struct media_device *mdev)
> +{
> +}
>  static inline int media_device_register_entity(struct media_device *mdev,
>  						struct media_entity *entity)
>  {
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ