lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening linux-cve-announce PHC | |
Open Source and information security mailing list archives
| ||
|
Message-Id: <1464072626-21161-1-git-send-email-treeze.taeung@gmail.com> Date: Tue, 24 May 2016 15:50:19 +0900 From: Taeung Song <treeze.taeung@...il.com> To: Arnaldo Carvalho de Melo <acme@...nel.org> Cc: linux-kernel@...r.kernel.org, Jiri Olsa <jolsa@...nel.org>, Namhyung Kim <namhyung@...nel.org>, Ingo Molnar <mingo@...nel.org>, Peter Zijlstra <peterz@...radead.org>, Alexander Shishkin <alexander.shishkin@...ux.intel.com>, Masami Hiramatsu <masami.hiramatsu.pt@...achi.com>, Taeung Song <treeze.taeung@...il.com> Subject: [PATCH v3 0/7] perf config: Introduce default config key-value pairs arrays When initializing default perf config values, we currently use values of actual type(int, bool, char *, etc.) For example, If there isn't user config value at ~/.perfconfig for 'annotate.use_offset' config variable, default value for it is 'true' bool type value in perf like below. At ui/browsers/annoate.c static struct annotate_browser_opt { bool hide_src_code, use_offset, jump_arrows, show_linenr, show_nr_jumps, show_total_period; } annotate_browser__opts = { .use_offset = true, .jump_arrows = true, }; By the way, I suggest using new config arrays that have all default config key-value pairs and then initializing default config values with them. Because if we do, we can manage default perf config values at one spot (like util/config.c) and It can be easy and simple to modify default config values or add new configs. For example, If we use new default config arrays and there isn't user config value for 'annoate.use_offset' default value for it will be set as annotate_config_items[CONFIG_ANNOATE_USE_OFFSET].value instead of actual boolean type value 'true'. IMHO, I think it is needed to use new default config arrays to manage default perf config values more effectively. And this pathset contains patchs for only 'colors' and 'annoate' section because waiting for other opinions. If you review this patchset, I'd appreciate it :-) Thanks, Taeung v3: - remove default config arrays for the rest sections except 'colors' and 'annotate' - use combined {fore, back}ground colors instead of each two color - introduce perf_default_config_init() that call all default_*_config_init() for each config section v2: - rename 'ui_browser__config_gcolors' to 'ui_browser__config_colors' (Arnaldo) - change 'ground colors' to '{back, fore}ground colors' (Arnaldo) - use strtok + ltrim instead of strchr and while (isspace(*++bg)); (Arnaldo) Taeung Song (7): perf config: Introduce default_config_item for default config key-value pairs perf config: Add 'colors' section default configs arrrays perf config: Use combined {fore,back}ground colors value instead of each two color perf config: Initialize ui_browser__colorsets with default config items perf config: Introduce perf_default_config_init() perf config: Add 'annotate' section default configs arrrays perf config: Initialize annotate_browser__opts with default config items tools/perf/perf.c | 7 ++++ tools/perf/ui/browser.c | 63 +++++++++++++++++-------------- tools/perf/ui/browser.h | 3 ++ tools/perf/ui/browsers/annotate.c | 15 ++++++-- tools/perf/util/cache.h | 2 + tools/perf/util/config.c | 28 +++++++++++++- tools/perf/util/config.h | 79 ++++++++++++++++++++++++++++++++++++++- 7 files changed, 163 insertions(+), 34 deletions(-) -- 2.5.0
Powered by blists - more mailing lists