lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [day] [month] [year] [list]
Date:	Tue, 24 May 2016 13:53:02 +0300
From:	Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To:	"Opensource [Adam Thomson]" <Adam.Thomson.Opensource@...semi.com>,
	Mark Brown <broonie@...nel.org>,
	Liam Girdwood <lgirdwood@...il.com>,
	Jaroslav Kysela <perex@...ex.cz>,
	Takashi Iwai <tiwai@...e.com>,
	Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
	Robert Moore <robert.moore@...el.com>,
	Lv Zheng <lv.zheng@...el.com>,
	"Rafael J.Wysocki" <rafael.j.wysocki@...el.com>,
	Len Brown <lenb@...nel.org>
Cc:	"alsa-devel@...a-project.org" <alsa-devel@...a-project.org>,
	"linux-acpi@...r.kernel.org" <linux-acpi@...r.kernel.org>,
	"devel@...ica.org" <devel@...ica.org>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	Support Opensource <Support.Opensource@...semi.com>,
	Sathyanarayana Nujella <sathyanarayana.nujella@...el.com>,
	Suravee <Suravee.Suthikulpanit@....com>,
	Bjorn Helgaas <bhelgaas@...gle.com>,
	Hanjun Guo <hanjun.guo@...aro.org>,
	Mika Westerberg <mika.westerberg@...ux.intel.com>,
	Andrew Morton <akpm@...ux-foundation.org>,
	Heikki Krogerus <heikki.krogerus@...ux.intel.com>
Subject: Re: [PATCH v2 2/2] ASoC: da7219: Convert driver to use generic
 device/fwnode functions

On Mon, 2016-05-23 at 22:53 +0000, Opensource [Adam Thomson] wrote:
> On May 19, 2015 14:28, Andy Shevchenko wrote:
> 
> > > -static struct da7219_aad_pdata *da7219_aad_of_to_pdata(struct
> > > snd_soc_codec *codec)
> > > +static struct da7219_aad_pdata *da7219_aad_fw_to_pdata(struct
> > > snd_soc_codec *codec)
> > >  {
> > > -	struct device_node *np = codec->dev->of_node;
> > > -	struct device_node *aad_np = of_find_node_by_name(np,
> > > "da7219_aad");
> > > +	struct device *dev = codec->dev;
> > > +	struct i2c_client *i2c = to_i2c_client(dev);
> > > +	struct fwnode_handle *aad_np =
> > > +		device_get_named_child_node(dev, "da7219_aad");
> > 
> > I would suggest to do an assignment below...
> > 
> > >  	struct da7219_aad_pdata *aad_pdata;
> > > -	const char *of_str;
> > > -	u32 of_val32;
> > > +	const char *fw_str;
> > > +	u32 fw_val32;
> > > 
> > 
> > 
> > ...right here.
> > Same amount of LOC, but less difficult to see from where aad_np
> > comes.
> > 
> > >  	if (!aad_np)
> > >  		return NULL;
> > > 
> 
> To be fair the allocation of 'aad_np' is only a few lines above so
> this really
> doesn't seem to make much difference in my opinion. It really
> shouldn't be hard
> for someone to spot where it's allocated.

Better to have it exactly before check. Just a readability and future
maintenance. (Someone might insert something in between, and a matter of
fact already did)

Though I agree this is minor.

> 
> > > @@ -769,9 +768,9 @@ int da7219_aad_init(struct snd_soc_codec
> > > *codec)
> > >  	da7219->aad = da7219_aad;
> > >  	da7219_aad->codec = codec;
> > > 
> > > -	/* Handle any DT/platform data */
> > > -	if ((codec->dev->of_node) && (da7219->pdata))
> > > -		da7219->pdata->aad_pdata =
> > > da7219_aad_of_to_pdata(codec);
> > > +	/* Handle any DT/ACPI/platform data */
> > > +     if ((da7219->pdata) && (!da7219->pdata->aad_pdata))
> > 
> > Redundant parens, twice.
> 
> Not essential, but looks cleaner to me. Unless there's a real demand
> to change,
> I'd like to leave this as is.

It's really unusual pattern and doesn't add any value

Compare
 if ((da7219->pdata) && (!da7219->pdata->aad_pdata)) 
to
 if (da7219->pdata && !da7219->pdata->aad_pdata)

Latter looks cleaner.

-- 
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Intel Finland Oy

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ