[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20160701075559.GA11902@gmail.com>
Date: Fri, 1 Jul 2016 09:55:59 +0200
From: Ingo Molnar <mingo@...nel.org>
To: Tim Chen <tim.c.chen@...ux.intel.com>
Cc: "H. Peter Anvin" <hpa@...or.com>,
Dan Carpenter <dan.carpenter@...cle.com>,
Herbert Xu <herbert@...dor.apana.org.au>,
"David S. Miller" <davem@...emloft.net>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, x86@...nel.org,
Megha Dey <megha.dey@...el.com>,
"Wang, Rui Y" <rui.y.wang@...el.com>,
Denys Vlasenko <dvlasenk@...hat.com>,
Xiaodong Liu <xiaodong.liu@...el.com>,
linux-crypto@...r.kernel.org, linux-kernel@...r.kernel.org,
kernel-janitors@...r.kernel.org
Subject: Re: [patch] crypto: sha256-mb - cleanup a || vs | typo
* Tim Chen <tim.c.chen@...ux.intel.com> wrote:
> On Wed, 2016-06-29 at 10:05 -0700, H. Peter Anvin wrote:
> > On 06/29/16 07:42, Dan Carpenter wrote:
> > >
> > > >
> > > > >
> > > > > and | behave basically the same here but || is intended. It causes a
> > > static checker warning to mix up bitwise and logical operations.
> > >
> > > Signed-off-by: Dan Carpenter <dan.carpenter@...cle.com>
> > >
> > > diff --git a/arch/x86/crypto/sha256-mb/sha256_mb.c b/arch/x86/crypto/sha256-mb/sha256_mb.c
> > > index c9d5dcc..4ec895a 100644
> > > --- a/arch/x86/crypto/sha256-mb/sha256_mb.c
> > > +++ b/arch/x86/crypto/sha256-mb/sha256_mb.c
> > > @@ -299,7 +299,7 @@ static struct sha256_hash_ctx *sha256_ctx_mgr_submit(struct sha256_ctx_mgr *mgr,
> > > * Or if the user's buffer contains less than a whole block,
> > > * append as much as possible to the extra block.
> > > */
> > > - if ((ctx->partial_block_buffer_length) | (len < SHA256_BLOCK_SIZE)) {
> > > + if ((ctx->partial_block_buffer_length) || (len < SHA256_BLOCK_SIZE)) {
> > > /* Compute how many bytes to copy from user buffer into
> > > * extra block
> > > */
> > >
> > As far as I know the | was an intentional optimization, so you may way
> > to look at the generated code.
> >
> > -hpa
> >
>
> Yes, this is an intentional optimization. [...]
Please don't do intentional optimizations while mixing them with a very ugly
coding style:
if ((ctx->partial_block_buffer_length) | (len < SHA256_BLOCK_SIZE)) {
The extra, unnecessary parantheses around ctx->partial_block_buffer_length will
make the ordinary reader assume that the person who wrote the code was unsure
about basic C syntax details and typoed the '|' as well ...
Also, for heaven's (and readability's) sake, pick shorter structure field names.
What's wrong with ctx->partial_block_buf_len?
Also, even if the '|' was intentional - wouldn't it result in better code to use
'||'?
Plus:
> > > /* Compute how many bytes to copy from user buffer into
> > > * extra block
> > > */
please use the customary (multi-line) comment style:
/*
* Comment .....
* ...... goes here.
*/
specified in Documentation/CodingStyle.
Thanks,
Ingo
Powered by blists - more mailing lists