[<prev] [next>] [day] [month] [year] [list]
Message-Id: <1467372243-15858-1-git-send-email-mark.rutland@arm.com>
Date: Fri, 1 Jul 2016 12:24:03 +0100
From: Mark Rutland <mark.rutland@....com>
To: linux-kernel@...r.kernel.org
Cc: Mark Rutland <mark.rutland@....com>,
Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
Arnaldo Carvalho de Melo <acme@...nel.org>,
Jiri Olsa <jolsa@...nel.org>
Subject: [PATCH] tools: perf: remove redundant evsel logic
The only caller of perf_evsel__alloc_fd is __perf_evsel__open, which
already has to explicitly handle the case when evsel->system_wide is
true (and therefore nthreads == 1), such that the number of FDs opened
matches the number of FDs it allocates space for.
Remove the duplicate logic and have perf_evsel__alloc_fd trust its
caller to provide the right number of threads.
Signed-off-by: Mark Rutland <mark.rutland@....com>
Cc: Alexander Shishkin <alexander.shishkin@...ux.intel.com>
Cc: Arnaldo Carvalho de Melo <acme@...nel.org>
Cc: Jiri Olsa <jolsa@...nel.org>
---
tools/perf/util/evsel.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/tools/perf/util/evsel.c b/tools/perf/util/evsel.c
index 5d7037e..a1fa1c2 100644
--- a/tools/perf/util/evsel.c
+++ b/tools/perf/util/evsel.c
@@ -926,9 +926,6 @@ static int perf_evsel__alloc_fd(struct perf_evsel *evsel, int ncpus, int nthread
{
int cpu, thread;
- if (evsel->system_wide)
- nthreads = 1;
-
evsel->fd = xyarray__new(ncpus, nthreads, sizeof(int));
if (evsel->fd) {
--
1.9.1
Powered by blists - more mailing lists