lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAGXu5j+fwuo+E=4An6wUG6c0SnpX6XDW-shU18bU9xEc9XN=PQ@mail.gmail.com>
Date:	Tue, 12 Jul 2016 14:42:22 -0400
From:	Kees Cook <keescook@...omium.org>
To:	Greg KH <gregkh@...uxfoundation.org>
Cc:	LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PULL] lkdtm update (next)

On Thu, Jul 7, 2016 at 2:14 PM, Kees Cook <keescook@...omium.org> wrote:
> Hi,
>
> Please pull these lkdtm changes for next.

Friendly ping... I'd like this refactor to make it in time for the 4.8
merge window. :)

-Kees

>
> Thanks!
>
> -Kees
>
> The following changes since commit e2402b1d214e5d50e807773563d590115a161f45:
>
>   nvmem: imx-ocotp: Fix assignment warning. (2016-06-25 07:42:55 -0700)
>
> are available in the git repository at:
>
>   git://git.kernel.org/pub/scm/linux/kernel/git/kees/linux.git tags/lkdtm-next
>
> for you to fetch changes up to c479e3fd88703c4b1049d7102a3fa8c6b3affef5:
>
>   lkdtm: use struct arrays instead of enums (2016-07-07 11:09:27 -0700)
>
> ----------------------------------------------------------------
> refactoring for multiple source files and better layout
>
> ----------------------------------------------------------------
> Kees Cook (12):
>       lkdtm: add usercopy test for blocking kernel text
>       lkdtm: drop "alloc_size" parameter
>       lkdtm: split usercopy tests to separate file
>       lkdtm: split memory permissions tests to separate file
>       lkdtm: split heap corruption tests to separate file
>       lkdtm: split remaining logic bug tests to separate file
>       lkdtm: remove intentional off-by-one array access
>       lkdtm: rename "count" to "crash_count"
>       lkdtm: rename globals for clarity
>       lkdtm: reorganize module paramaters
>       lkdtm: move jprobe entry points to start of source
>       lkdtm: use struct arrays instead of enums
>
>  drivers/misc/Makefile         |    4 +
>  drivers/misc/lkdtm.h          |   51 ++
>  drivers/misc/lkdtm_bugs.c     |  152 +++++
>  drivers/misc/lkdtm_core.c     | 1246 ++++++++---------------------------------
>  drivers/misc/lkdtm_heap.c     |  146 +++++
>  drivers/misc/lkdtm_perms.c    |  203 +++++++
>  drivers/misc/lkdtm_usercopy.c |  315 +++++++++++
>  7 files changed, 1106 insertions(+), 1011 deletions(-)
>  create mode 100644 drivers/misc/lkdtm_bugs.c
>  create mode 100644 drivers/misc/lkdtm_heap.c
>  create mode 100644 drivers/misc/lkdtm_perms.c
>  create mode 100644 drivers/misc/lkdtm_usercopy.c
>
> --
> Kees Cook
> Chrome OS & Brillo Security



-- 
Kees Cook
Chrome OS & Brillo Security

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ