[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1469627517.16837.9.camel@opteya.com>
Date: Wed, 27 Jul 2016 15:51:57 +0200
From: Yann Droneaud <ydroneaud@...eya.com>
To: kernel-hardening@...ts.openwall.com, william.c.roberts@...el.com,
linux-mm@...r.kernel.org, linux-kernel@...r.kernel.org
Cc: Jason Cooper <jason@...edaemon.net>, linux@....linux.org.uk,
akpm@...ux-foundation.org, keescook@...omium.org, tytso@....edu,
arnd@...db.de, gregkh@...uxfoundation.org, catalin.marinas@....com,
will.deacon@....com, ralf@...ux-mips.org, benh@...nel.crashing.org,
paulus@...ba.org, mpe@...erman.id.au, davem@...emloft.net,
tglx@...utronix.de, mingo@...hat.com, hpa@...or.com,
x86@...nel.org, viro@...iv.linux.org.uk, nnk@...gle.com,
jeffv@...gle.com, alyzyn@...roid.com, dcashman@...roid.com
Subject: Re: [kernel-hardening] [RFC patch 1/6] random: Simplify API for
random address requests
Hi,
Le mardi 26 juillet 2016 à 03:01 +0000, Jason Cooper a écrit :
> To date, all callers of randomize_range() have set the length to 0,
> and check for a zero return value. For the current callers, the only
> way to get zero returned is if end <= start. Since they are all
> adding a constant to the start address, this is unnecessary.
>
I agree.
> We can remove a bunch of needless checks by simplifying the API to do
> just what everyone wants, return an address between [start, start +
> range].
>
I agree.
For the record:
http://lkml.kernel.org/r/cover.1390770607.git.ydroneaud@opteya.com
> While we're here, s/get_random_int/get_random_long/. No current call
> site is adversely affected by get_random_int(), since all current
> range requests are < MAX_UINT. However, we should match caller
> expectations to avoid coming up short (ha!) in the future.
>
> Signed-off-by: Jason Cooper <jason@...edaemon.net>
> ---
> drivers/char/random.c | 17 ++++-------------
> include/linux/random.h | 2 +-
> 2 files changed, 5 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/char/random.c b/drivers/char/random.c
> index 0158d3bff7e5..1251cb2cbab2 100644
> --- a/drivers/char/random.c
> +++ b/drivers/char/random.c
> @@ -1822,22 +1822,13 @@ unsigned long get_random_long(void)
> EXPORT_SYMBOL(get_random_long);
>
> /*
> - * randomize_range() returns a start address such that
> - *
> - * [...... <range> .....]
> - * start end
> - *
> - * a <range> with size "len" starting at the return value is inside
> in the
> - * area defined by [start, end], but is otherwise randomized.
> + * randomize_addr() returns a page aligned address within [start,
> start +
> + * range]
> */
> unsigned long
> -randomize_range(unsigned long start, unsigned long end, unsigned
> long len)
> +randomize_addr(unsigned long start, unsigned long range)
> {
> - unsigned long range = end - len - start;
> -
> - if (end <= start + len)
> - return 0;
> - return PAGE_ALIGN(get_random_int() % range + start);
> + return PAGE_ALIGN(get_random_long() % range + start);
> }
>
> /* Interface for in-kernel drivers of true hardware RNGs.
> diff --git a/include/linux/random.h b/include/linux/random.h
> index e47e533742b5..1ad877a98186 100644
> --- a/include/linux/random.h
> +++ b/include/linux/random.h
> @@ -34,7 +34,7 @@ extern const struct file_operations random_fops,
> urandom_fops;
>
> unsigned int get_random_int(void);
> unsigned long get_random_long(void);
> -unsigned long randomize_range(unsigned long start, unsigned long
> end, unsigned long len);
> +unsigned long randomize_addr(unsigned long start, unsigned long
> range);
>
> u32 prandom_u32(void);
> void prandom_bytes(void *buf, size_t nbytes);
Powered by blists - more mailing lists