[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.10.1608011336590.3188@hadrien>
Date: Mon, 1 Aug 2016 13:37:36 +0200 (CEST)
From: Julia Lawall <julia.lawall@...6.fr>
To: SF Markus Elfring <elfring@...rs.sourceforge.net>
cc: Amitoj Kaur Chawla <amitoj1606@...il.com>,
LKML <linux-kernel@...r.kernel.org>,
Coccinelle <cocci@...teme.lip6.fr>,
Gilles Muller <Gilles.Muller@...6.fr>,
Michal Marek <mmarek@...e.com>,
Nicolas Palix <nicolas.palix@...g.fr>
Subject: Re: [Cocci] [PATCH v3] Coccinelle: Script to replace allocate and
memset with zalloc functions
On Mon, 1 Aug 2016, SF Markus Elfring wrote:
> > +@vz1 depends on patch && !context && !org && !report@
> > +type T;
> > +T *d;
> > +statement S;
> > +@@
> > +
> > + d =
> > +- vmalloc
> > ++ vzalloc
> > + (...);
> > + if (!d) S
> > +- memset(d, 0, sizeof(T));
> > +
> > +@vz2 depends on patch && !context && !org && !report@
> > +expression d;
> > +statement S;
> > +@@
> > +
> > + d =
> > +- vmalloc
> > ++ vzalloc
> > + (...);
> > + if (!d) S
> > +- memset(d, 0, sizeof(*d));
>
> I suggest to take another look at a few implementation details.
>
> 1. Would it make sense to merge such SmPL rules into one
> so that code duplication could be reduced a bit
> in such a script?
I think it would suffer in readability. Perhaps in performance as well.
julia
>
> 2. How do you think about to extend the shown check list
> with the function "kvm_kvzalloc"?
>
> 3. Do you want to maintain a growing (?) function name list manually?
>
> Regards,
> Markus
>
Powered by blists - more mailing lists