[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <579F635E.6090505@laposte.net>
Date: Mon, 1 Aug 2016 16:57:34 +0200
From: Sebastian Frias <sf84@...oste.net>
To: Grant Likely <grant.likely@...retlab.ca>,
Marc Zyngier <marc.zyngier@....com>,
Thomas Gleixner <tglx@...utronix.de>,
Jason Cooper <jason@...edaemon.net>
Cc: LKML <linux-kernel@...r.kernel.org>, Mason <slash.tmp@...e.fr>
Subject: [PATCH v2] irqdomain: factorise irq_domain_xlate_onetwocell()
Commit 16b2e6e2f31d ("irq_domain: Create common xlate functions that device
drivers can use") introduced three similar functions:
irq_domain_xlate_onecell()
irq_domain_xlate_twocell()
irq_domain_xlate_onetwocell()
yet the last one, irq_domain_xlate_onetwocell(), can be factored to use the
two previous ones to avoid code duplication.
Fixes: 16b2e6e2f31d ("irq_domain: Create common xlate functions that device
drivers can use")
Signed-off-by: Sebastian Frias <sf84@...oste.net>
---
NOTE: the factored code is not strictly the same in the sense that
16b2e6e2f31d returns "intspec[1]" as 'out_type', while this patch would
make it return "intspec[1] & IRQ_TYPE_SENSE_MASK".
Feel free to comment on that matter.
---
kernel/irq/irqdomain.c | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/kernel/irq/irqdomain.c b/kernel/irq/irqdomain.c
index bee8b02..125a28c 100644
--- a/kernel/irq/irqdomain.c
+++ b/kernel/irq/irqdomain.c
@@ -839,9 +839,12 @@ int irq_domain_xlate_onetwocell(struct irq_domain *d,
{
if (WARN_ON(intsize < 1))
return -EINVAL;
- *out_hwirq = intspec[0];
- *out_type = (intsize > 1) ? intspec[1] : IRQ_TYPE_NONE;
- return 0;
+ if (intsize == 1)
+ return irq_domain_xlate_onecell(d, ctrlr, intspec, intsize,
+ out_hwirq, out_type);
+ else
+ return irq_domain_xlate_twocell(d, ctrlr, intspec, intsize,
+ out_hwirq, out_type);
}
EXPORT_SYMBOL_GPL(irq_domain_xlate_onetwocell);
--
1.7.11.2
Powered by blists - more mailing lists