[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20160802115059.5588-1-baolex.ni@intel.com>
Date: Tue, 2 Aug 2016 19:50:59 +0800
From: Baole Ni <baolex.ni@...el.com>
To: konrad.wilk@...cle.com, boris.ostrovsky@...cle.com,
david.vrabel@...rix.com, jgross@...e.com, bhelgaas@...gle.com,
m.chehab@...sung.com, pawel@...iak.com, m.szyprowski@...sung.com,
kyungmin.park@...sung.com, k.kozlowski@...sung.com
Cc: linux-pcmcia@...ts.infradead.org, linux-kernel@...r.kernel.org,
chuansheng.liu@...el.com, baolex.ni@...el.com
Subject: [PATCH 0834/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
Signed-off-by: Baole Ni <baolex.ni@...el.com>
---
drivers/pcmcia/soc_common.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/pcmcia/soc_common.c b/drivers/pcmcia/soc_common.c
index eed5e9c..ed868fd 100644
--- a/drivers/pcmcia/soc_common.c
+++ b/drivers/pcmcia/soc_common.c
@@ -54,7 +54,7 @@ static irqreturn_t soc_common_pcmcia_interrupt(int irq, void *dev);
#ifdef CONFIG_PCMCIA_DEBUG
static int pc_debug;
-module_param(pc_debug, int, 0644);
+module_param(pc_debug, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
void soc_pcmcia_debug(struct soc_pcmcia_socket *skt, const char *func,
int lvl, const char *fmt, ...)
--
2.9.2
Powered by blists - more mailing lists