[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20160802161144.538ee7a6.cornelia.huck@de.ibm.com>
Date: Tue, 2 Aug 2016 16:11:44 +0200
From: Cornelia Huck <cornelia.huck@...ibm.com>
To: Baole Ni <baolex.ni@...el.com>
Cc: borntraeger@...ibm.com, schwidefsky@...ibm.com,
heiko.carstens@...ibm.com, dwmw2@...radead.org,
m.chehab@...sung.com, pawel@...iak.com, m.szyprowski@...sung.com,
kyungmin.park@...sung.com, k.kozlowski@...sung.com,
linux-s390@...r.kernel.org,
virtualization@...ts.linux-foundation.org, kvm@...r.kernel.org,
linux-kernel@...r.kernel.org, chuansheng.liu@...el.com
Subject: Re: [PATCH 0904/1285] Replace numeric parameter like 0444 with
macro
On Tue, 2 Aug 2016 19:56:46 +0800
Baole Ni <baolex.ni@...el.com> wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
>
> Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
> Signed-off-by: Baole Ni <baolex.ni@...el.com>
> ---
> drivers/s390/virtio/virtio_ccw.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/s390/virtio/virtio_ccw.c b/drivers/s390/virtio/virtio_ccw.c
> index 8688ad4..56d3671 100644
> --- a/drivers/s390/virtio/virtio_ccw.c
> +++ b/drivers/s390/virtio/virtio_ccw.c
> @@ -1074,7 +1074,7 @@ static unsigned long devs_no_auto[__MAX_SSID + 1][__DEV_WORDS];
>
> static char *no_auto = "";
>
> -module_param(no_auto, charp, 0444);
> +module_param(no_auto, charp, S_IRUSR | S_IRGRP | S_IROTH);
> MODULE_PARM_DESC(no_auto, "list of ccw bus id ranges not to be auto-onlined");
>
> static int virtio_ccw_check_autoonline(struct ccw_device *cdev)
NACK. I find 0444 more readable.
<And some general remarks: Your patches are lacking a proper component
prefix and have a rather long list of people on to: ...and sending
1000+ patches to lkml at once is not a very good idea either.>
Powered by blists - more mailing lists