[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20160802172756.GA5012@dtor-ws>
Date: Tue, 2 Aug 2016 10:27:56 -0700
From: Dmitry Torokhov <dmitry.torokhov@...il.com>
To: Baole Ni <baolex.ni@...el.com>
Cc: hal.rosenstock@...il.com, dledford@...hat.com,
sean.hefty@...el.com, bp@...en8.de, linux-input@...r.kernel.org,
linux-kernel@...r.kernel.org, haibo.chen@...escale.com,
andrey.gelman@...pulab.co.il, broonie@...nel.org, afd@...com,
javier@....samsung.com, chuansheng.liu@...el.com
Subject: Re: [PATCH 0290/1285] Replace numeric parameter like 0444 with macro
On Tue, Aug 02, 2016 at 06:57:11PM +0800, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
>
> Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
> Signed-off-by: Baole Ni <baolex.ni@...el.com>
> ---
> drivers/input/touchscreen/ads7846.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/input/touchscreen/ads7846.c b/drivers/input/touchscreen/ads7846.c
> index a61b215..0f882cb 100644
> --- a/drivers/input/touchscreen/ads7846.c
> +++ b/drivers/input/touchscreen/ads7846.c
> @@ -591,7 +591,7 @@ static ssize_t ads7846_disable_store(struct device *dev,
> return count;
> }
>
> -static DEVICE_ATTR(disable, 0664, ads7846_disable_show, ads7846_disable_store);
> +static DEVICE_ATTR(disable, S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH, ads7846_disable_show, ads7846_disable_store);
No, this does not improve neither robustness nor readability.
Thanks.
--
Dmitry
Powered by blists - more mailing lists